Unexpected behavior occurs with the use of Microsoft Internet Explorer in a Citrix XenApp or Citrix XenDesktop session

Version 1

    Problem

    Consider the following scenario:
    • RES ONE Workspace is used in a Citrix XenApp or Citrix XenDesktop session.
    • A managed application is created for Microsoft Internet Explorer.
    In this scenario unexpected behavior might occur. Some examples are:
    • Only one instance of Microsoft Internet Explorer can be started, although Maximum Instances is configured with a value larger then '1'.
    • User Registry actions on another application then Microsoft Internet Explorer are not executed when both Microsoft Internet Explorer as the other application are configured to autolaunch at session start.
     

    Cause

    Microsoft Internet Explorer is started from one of the following paths:
    • C:\Program Files (x86)\Citrix\System32 for 64-bit systems
    • C:\Program Files\Citrix\System32 for 32-bit systems.
    This is actually a Citrix executable that is used by Citrix for content redirection.

    If a managed application for iexplore.exe is created in the RES ONE Workspace Console on a Citrix XenApp or Citrix XenDesktop server, then this path is resolved.


     

    Solution

    Use the default path for Internet Explorer: C:\Program Files\Internet Explorer\iexplore.exe.