Clicking on a link in a jumplist results in an error: "Cannot find the file specified"

Version 3

    Problem

    Consider the following scenario:
    • RES ONE Workspace session is running.
    • A RES ONE Workspace managed application is launched.
    • The shortcuts is pointing to "%respfdir%\pwrgate.exe" xxxx   in which xxxx is the RES ONE Workspace managed applications ID.
    • In the RES ONE Workspace console, File types are configured upon the RES ONE Workspace managed application at Composition > Applications : Application Properties > File Types.
    When trying to open a document by clicking a link from the applications jumplist Pinned or Recent items, an error message is shown: "Cannot find the file specified".

     

    Cause

    The link stored in the RES ONE Workspace managed applications jumplist is referring to the wrong location.

     

    Solution

    Configure the following:
    • On the RES ONE Managed application configure Process Interception and remove the File types set (if any).
               Read this article on HOWTO configure Process Interception and remove the set File types:

    • Set the InterceptManagedApps registry key to force the Target to point to the original executable instead of "%respfdir%\pwrgate.exe" xxxx   in which xxxx is the RES ONE Workspace managed applications ID.
               Read this article on HOWTO set the InterceptManagedApps registry key:

    NOTES:
    • Configuring this may result in the loss of the current jumplist, a new jumplist will automatically be generated by Microsoft Windows when using the application.
    • Links in the jumplist which generate the error will not be repaired, they should be removed (right click on the link in the jumplist and select Remove from this list or Unpin from this list).
    • The application needs to be re-pinned If the application was pinned on the taskbar before configuring the regkey InterceptManagedApps= Yes" in order to see the correct jumplist with the recent items. Application stacking will also work again after this. (Right click on shortcut in the taskbar and select Unpin from taskbar).