Citrix published application cannot be started

Version 1

    Problem

    Consider the following:

    - A RES ONE Workspace managed application is published to Citrix StoreFront.
    - Citrix Receiver Single Sign-On is working.
    - The published application can be started via StoreWeb.
    - Starting the application by the RES ONE Workspace managed icon returns an error: "Application cannot be started" or "Application cannot be started (Invalid reference)".


     

    Cause

    A non-secure StoreFront server is used.

    By default, the Citrix Receiver and AuthManager do not accept HTTP traffic, only HTTPS.


     

    Solution

    As per the Citrix KB article: http://support.citrix.com/article/CTX134341, add the following keys to the registry:

    Key: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Citrix\AuthManager
    Type: REG_SZ
    Value Name: ConnectionSecurityMode
    Value Data: Any

    Key: HKEY_LOCAL_MACHINE \SOFTWARE\Wow6432Node\Citrix\Dazzle
    Type: REG_SZ
    Value Name: AllowAddStore
    Value Data: A

    Key: HKEY_LOCAL_MACHINE \SOFTWARE\Wow6432Node\Citrix\Dazzle
    Type: REG_SZ
    Value Name: AllowSavePwd
    Value Data: A

    Add your non-secure Storefront server to the Delivery Group.