The default printer has not been set

Version 1

    Problem

    The default printer has not been set.
    When logging on, the user will be presented with the error message that no default printer is present. However, when viewing Printing Preferences, a default printer has been selected. A default printer will also be present in the "pwruser.ini" file and the users event log will not display any printer related problems.

    Solution

    Try out one of the following solutions to solve the problem:

    Solution 1:

    Change RDP protocol properties and set no other default printer in RES Workspace Manager

    In the RDP protocol properties, the following options need to be set:

    1. At the "client settings", "connect client printers at logon" and "default to main client printer" need to be selected.
    2. In RES Workspace Manager, no printers may be set to "default", because this would overrule the printer settings made for the RDP protocol.
     

    Solution 2:

    Default to main client printer

    The local client printer probably has been set as default. This can be checked in the "Advanced" section of Printing Preferences. To make sure the local printer is not set as default, the applicable option must be disabled either at user level in the Active Directory or at the RDP protocol:

    Active Directory Users and Computers - <Username> - Environment - Default to main client printer

    - or -

    Terminal Services Configuration - Connections - RDP-TCP - Client Settings - Default to main client printer
     

    Solution 3:
     
    Remove MessageDefaultPrinter=Yes from the pwruser.ini file.

    If the value of the pwruser.ini file in Composition > Actions By Type > Files and Folders > user Home Directory has been set to "MessageDefaultPrinter=Yes", set the value to "No".