Starting a shortcut results in a warning message: 'Open File - Security Warning

Version 1

    Problem

    When trying to open a shortcut from e.g. the Desktop, Homedrive, My Documents, etc. a File Open - Security Warning appears and the user needs to select 'Open' or 'Cancel':
     
    Open File - Security Warning
     
    Do you want to open this file?
     
    Name: <shortcutname.lnk>
    Publisher: Unknown Publisher
    Type: Shortcut
    From: <Driveletter>

     

    Cause

    This behavior is mostly seen when My Documents and e.g. the Desktop is redirected to a network location and is reproducible in a normal Windows session without RES Workspace Manager.
     
    Microsoft Internet Explorer Enhanced Security (IEES) restricts access to scripts, executable files, and other potentially unsafe files on a UNC path, unless the UNC path is added to the Local Intranet zone explicitly.
     

    Solution

    Try out one of the following solutions to solve the problem:

    Solution 1:
     
    Add \\server to the Local Intranet Zone

    If you want to access \\server\share\explorer.lnk, you must add \\server to the Local intranet zone.
     
    1) Start Microsoft Internet Explorer on the Terminal Server.
    2) Browse to Tools > Internet Options > Security > Local Intranet zone. 
    3) Add the UNC name of the server where the application is located. (\\server)
     
    Or configure this in a GPO:
     
    1) GPO: User Configuration\Windows Settings\Internet Explorer Maintenance\Security\Security zones and Content ratings 
    2) Modify the settings.
     
    Or add the registry key with RES Workspace Manager:
     
    Key:

    System Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\ZoneMap\EscDomains]
    Data Type: DWORD
    Value Name: <Filename>
    Value Data: 00000001

     
    Solution 2:

      Add .lnk files to the LowRiskFileTypes to suppress the dialog box.
       
      To do this add the following registry key:
     
      System Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Associations]
      Data Type: REG_SZ
      Value Name: LowRiskFileTypes
      Value Data: .lnk
       
      Or configure this in a GPO:
       
      1) GPO: User Configuration\Administrative Templates\Windows Components\AttachmentManager
      2) Set "Inclusion list for low filetypes" to enabled and configure the policy with .lnk