Default printer not always saved if it is changed in the Control Panel applet Devices and Printers

Version 1

    Problem

    Default printer not always saved if it is changed in the Control Panel applet Devices and Printers.

    Consider the following scenario:

    - At Composition > Actions By Type > Printers, on the Printers tab, several printers were configured.
    - At Composition > Desktop > Lockdown and Behavior, in the Workspace Composer section, the option Do not refresh Workspace when network connectivity changes was not selected.
    - A user logged in to an RES Workspace Manager session and changed the default printer using the Microsoft Windows Control Panel.
    - The user disconnect the session.
    - The user reconnect to the session and changes to another default printer.
    - The user logged off.
    - At next logon the default printer is set to the default printer before the reconnect.

    Cause

    Default printer not always saved if it is changed in the Control Panel applet Devices and Printers.

    Solution

    This issue is resolved in RES Workspace Manager 2014 SR2.
     
    In case the Service Release is not (yet) available or in case the Service Release cannot be installed, a revision containing this update is available on request at RES Support.
     
    IMPORTANT: A revision contains multiple fixes. Only apply this revision when you are experiencing a specific problem. Unless you are severely impacted by this specific problem, RES Software recommends that you wait for the next service release containing these fixes.