Secure printing passwords and/or pin codes are not restored with User Settings for Xerox and Ricoh printers

Version 1

    Problem

    Specific printers deliver the possibility to secure printing by setting a password and pin code.

    This option can be switched on in the printer driver. When using a Xerox or Ricoh printer, the password and/or pin code are not restored.


     

    Cause

    Secure printing passwords are stored in the Microsoft protected storage registry.

     

    Solution

    This issue is resolved in RES Workspace Manager 2012 SR4.
     
    In case the Service Release is not (yet) available or in case the Service Release cannot be installed, a revision containing this update is available on request at RES Support.
     
    IMPORTANT: A revision contains multiple fixes. Only apply this revision when you are experiencing a specific problem. Unless you are severely impacted by this specific problem, RES Software recommends that you wait for the next service release containing these fixes.


    Workaround:

    Capture %AppData%\Microsoft\Protect as a targeted item in User Settings.