Microsoft Internet Explorer proxy is not set correctly with User Registry

Version 3

    Problem

    The Microsoft Internet Explorer proxy settings are not set when using User Registry in RES ONE Workspace. When launching Microsoft Internet Explorer, the settings have not been set or the proxy settings have reverted to a previous setting.

     

    Cause

    This behavior occurs when Automatically Detect Settings is configured as Enabled in the DefaultConnectionSettings value of [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Connections].

     

    Solution

    Set the Automatically Detect Settings to Disabled in the DefaultConnectionSettings value of [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Connections] to solve this issue.

    Also, make sure Active Setup is enabled. The option Disable Active Setup (skips first-time shell init) under Composition> Applications> Settings should be unticked.