Slow login on some of the RES Workspace Manager agents

Version 1

    Problem

    When logging on to a RES Workspace Manager session, the login process takes longer than expected. Logins for the same user on other machines are OK.
    Symtoms that may be seen during investigation are:
     
    • When logging on, the resop.exe process will use up to 100% of one CPU
    • If there is a tracefile, there are many rules containing the line: fstrExecuteJob; Result="LocalTimeout"
    • The user session is reported very late in the Workspace Analysis and the User Sessions tab of the RES PowerFuse / RES Workspace Manager Management Console

     

    Cause

    An older version of MSVBVM60.dll has been registered on the affected system. An installation of some older application could have copied an old MSVBVM60.DLL to the system32 folder and registered it in the Windows registry.
     
    The RESOP.EXE relies heavily on the MSVBVM60.dll. If an old version is used, this can cause longer than normal login times.

     

    Solution

    Please use the latest version of the MSVBVM60.dll. This dll is a component of the Visual Basic Runtine Pack, supplied by Microsoft.
    It can be downloaded from the internet or can be copied from another machine with the same operating system.