Concurrent licenses are not claimed when no named licenses are available during installation

Version 1

    Problem

    Consider the following scenario:
     
    In a mixed licensing environment there are two license pools available, for instance: 100 named licenses and 100 concurrent licenses. 
    In the named licensing pool there are no more licenses available, but in the concurrent license pool there are sufficient licenses available.
     
    When a user who is logging onto a laptop starts an RES ONE Workspace session, this user should normally receive a named license. When these licenses are not available, like in this scenario, the user should receive a concurrent license.

    Instead of receiving a license from the concurrent license pool, the user receives an error message "RES ONE Workspace cannot continue because no licenses are available."


     

    Cause

    In a mixed environment, when no more named licenses are available, a laptop license should be issued to users logging on to a laptop.
     
    By default, RES ONE Workspace does not issue this type of license, unless "CLAIMLAPTOPLICENSE=yes" is specified as an installation parameter during the RES ONE Workspace Agent setup.


     

    Solution

    Reinstalling the RES ONE Workspace Agent with the setup parameter "CLAIMLAPTOPLICENSE=yes" will resolve the issue by directing the agent to always claim a concurrent laptop license.