Post installation window not shown when logged on to a RES Workspace Manager session

Version 1

    Problem

    Certain applications are not able to present a window to a logged on user when this user is logged on to a RES Workspace Manager session.
     
    Applications currently known to encounter issues are;
    - McAfee Encrypted USB Client 1.5.1

     

    Cause

    Certain applications are programmed to interact to the program defined in the registry string "Shell" in the following registry location;
    "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon".
     
    Those applications need the explorer.exe to be in place to function properly.
     
    When setting a RES Workspace Manager Agent to run automatically the value of the "Shell" key is set to %respfdir%\pwrstart.exe.

     

    Solution

    Not related to RES Workspace Manager. This issue will occur with any application that changes the Shell key.
    The application vendor might have a solution for this issue by removing the dependency of the Shell key.