When logging in to a Citrix XenApp desktop, some users are getting a black screen

Version 1

    Problem

    When logging in to a Citrix XenApp desktop, some users are getting a black screen. Nothing further happens.

    Cause

    Several causes have been found which could trigger the problem. 

    The majority of them are related to drive mappings or folder redirections in logon scripts, user profiles and/or GPO’s, which point to an incorrect location or experience delays in being mapped during the logon process.


     

    Solution

    Check the Citrix knowledgebase for article CTX135782.
     
    Besides determining which drive mapping or folder redirection is causing the delay in the particular environment, the problem can be circumvented by adding/setting the following registry key on the XenApp server(s):
     
    Registry Key: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Citrix\Logon
    Name: DisableStatus
    Type: REG_DWORD
    Value: 00000001