Error message: "A problem has caused the application to stop working correctly" when starting a Microsoft App-V 5 application in compatibility mode

Version 1

    Problem

    An error message is displayed when starting a Microsoft App-V 5 application configured to start in compatibility mode.

    The message: "A problem has caused the application to stop working correctly. Please close the application".

    Although RES Workspace Manager Knowledge Base article "HOWTO: Start an application in Windows Application Compatibility Mode" is applied the error is presented.
    In a session without RES Workspace Manager the Microsoft App-V 5 application starts fine with the applied registry value mentioned in the article.

     

    Cause

    The compatibility mode registry value contains the path of the original Microsoft App-V 5 icon but lack the path of the application used in the RES Workspace Manager Command Line field.

     

    Solution

    As described in RES Knowledge Base article "HOWTO: Start an application in Windows Application Compatibility Mode" the registry location HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers contains the path of the application that must be run in compatibility mode.

    When the Microsoft App-V 5 application is running fine in compatibility mode, the Microsoft App-V 5 application path is added to the registry key. The following registry value can be found:
    C:\Users\%username%\Appdata\Local\Microsoft\AppV\Client\Integration\3a13.....15388\Root\FacilitiesPro Manager\bin\FacilitiyPro.exe

    To make the RES Workspace Manager managed application function in compatibility mode, the RES Workspace Manager Command Line path must be added to this key. Make sure to add the full path without any variables, for example:
    c:\ProgramData\App-V\3A13.....3BB\1466FAB5.....E12\Root\FacilityPro Manager\bin\FacilityPro.exe

    Don`t forget to add the right value data value as used for the original Microsoft App-V 5 location.