RES Workspace Manager Agents sometimes not displayed if using Scope Control

Version 1

    Problem

    Consider the following scenario:

    At User Context > Workspace Containers, Workspace Container "A" was created.
    On the Computer Control tab of the Workspace Container, Include all Agents was selected.

    At Administration > Administrative Roles, an Administrative role was created with the following settings:

    On the Settings tab of the Administrative Role, Modify access was given for Administration > Agents > Agents.
    On the Scope Control > Workspace Control tab of the Administrative Role, existing workspace container "A" was selected.
    On the Access Control tab, in the Identity section, user "X" was added.

    In the RES Workspace Manager environment, several Agents were present.

    User "X" opened the RES Workspace Manager Console.

    In this scenario, user "X" could access the Agents tab at Administration > Agents, but no RES Workspace Manager Agents were displayed.

     

    Cause

    Due to a coding error Scope control was not applied correctly.

     

    Solution

    This issue is resolved in RES Workspace Manager 2014 SR3.

    In case the Service Release is not (yet) available or in case the Service Release cannot be installed, a revision containing this update is available on request at RES Support.

    IMPORTANT: A revision contains multiple fixes. Only apply this revision when you are experiencing a specific problem. Unless you are severely impacted by this specific problem, RES Software recommends that you wait for the next service release containing these fixes.