RES Workspace Manager Relay Server stops with error: "Maximum number of queued transactions reached (maximum allowed = 50000)"

Version 1

    Problem

    RES Workspace Manager Relay Server stops with error: "Maximum number of queued transactions reached (maximum allowed = 50000)"

    In this case the folder C:\ProgramData\RES\Relay Server\{GUID}\Transactions will contain more than 50.000 transaction files.

     

    Cause

    There is a high CPU load on the database server. As a result the transactions of the RES Workspace Manager Relay Server are processed slower than new transactions that are received.

     

    Solution

    This issue is resolved in RES Workspace Manager Relay Server 2014 SR3.

    In case the Service Release is not (yet) available or in case the Service Release cannot be installed, a revision containing this update is available on request at RES Support.

    IMPORTANT: A revision contains multiple fixes. Only apply this revision when you are experiencing a specific problem. Unless you are severely impacted by this specific problem, RES Software recommends that you wait for the next service release containing these fixes.