Unable to start more than 1 Citrix XenDesktop 7.x VM Hosted Application

Version 1

    Problem

    When you publish a Citrix XenDesktop 7.x application with RES Workspace Manager you are unable to start more than 1 application. When you click on the second application, whether it`s from Citrix Storefront or the Windows Start menu, nothing happens.

     

    Cause

    While starting pwrgate.exe there is a trigger to restart Explorer.exe. When you start a published app with Citrix Xendesktop 7.x the process mmvdhost.exe imitates explorer.exe and therefore receives the trigger instead.

    After it stops it does not start anymore and any new applications will not be launched.

     

    Solution

    This issue is resolved in RES Workspace Manager 2014 SR3.

    In case the Service Release is not (yet) available or in case the Service Release cannot be installed, a revision containing this update is available on request at RES Support.

    IMPORTANT: A revision contains multiple fixes. Only apply this revision when you are experiencing a specific problem. Unless you are severely impacted by this specific problem, RES Software recommends that you wait for the next service release containing these fixes.