Error: Application can`t be started... (invalid reference)

Version 3

    Problem


    Consider the following scenario:
    • You have a Citrix XenApp infrastructure and application publishing is handled by RES ONE Workspace.
    • In the Instant Passthrough settings of the published application the following option is selected: Use an ICA file.
    • Citrix Receiver 4.x is used to launch the passthrough application.
    • RES Workspace Manager 2014 SR2 or higher is being used.
    In this case one of the following error message can be displayed when launching the application:
    • "Application can`t be started..."
    • "Application can`t be started... (invalid reference)"

    Cause

     

    Detection of Citrix Receiver 4 causes the custom ICA files to be ignored.

    Since RES Workspace Manager 2014 SR2 Citrix Receiver 4.x is supported.
    This means when the Citrix SelfService client is detected it will be used automatically. A configured Citrix Storefront or Web Interface is to be expected, according Citrix best practices.
    When this is not in place the error message will be displayed.

    As ICA files are not being supported and recommended by Citrix for a long time, this method is also not recommended by RES.

     

    Solution

     

    This issue can be solved by one of the following solutions:

    Solution 1:

    Enable Citrix XenApp Single Sign On.

    Instructions on how to enable Citrix XenApp Single Sign On can be found at: http://support.citrix.com/article/CTX200157


    Solution 2:

    Set a registry key to bypass the detection of the Selfservice plugin.

    However not recommended it is possible to disable the SelfService plugin detection to fallback to legacy mode and support the use of ICA files.

    The following key, supported from RES Workspace Manager 2014 SR2 Revision 2 (9.9.2.4), will bypass the SelfService plugin detection:

    32-bit:
    Key: HKEY_LOCAL_MACHINE\SOFTWARE\RES\Workspace Manager
    Value: DetectCitrixSelfServicePlugin
    Type: REG_SZ
    Data: no

    64-bit:
    Key: HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\RES\Workspace Manager
    Value: DetectCitrixSelfServicePlugin
    Type: REG_SZ
    Data: no

    This can be used as a temporary workaround.
    It is recommended to follow Citrix best practices and integrate Citrix Receiver with Citrix Storefront.


    Solution 3:

    Install a legacy version of Citrix Receiver of which the version number is lower than 4.
    This will cause RES ONE Workspace to revert to it`s legacy behavior regarding the handling of Citrix ICA files.

    Solution 4:

    Use the following registry setting to force a different behaviour of polling the Citrix Published Applicaitons with the SelfService executable based on https://support.citrix.com/article/CTX200337

    During logon the Citrix Selfservice.exe command is run with -ipoll -init -exit within RES ONE Workspace. This will poll the Citrix Published Applications and will create a xml file which corresponds to your Citrix Stores that are configured for Citrix Receiver SSO. There is a xml file created in the %LOCALAPPDATA%\citrix\selfservice. With the -ipoll switch the creation of the xml file can take up to 1 minute and more. There are also stub files created for every published app that will be integrated into the system. With the registry set you can invoke a different command line which does the polling without creating all the entries for these stub files. This will speed up the process of creating the xml file within a couple of seconds.This will use the -poll -init -exit functionality.

    [64bit Windows]
    Key: HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\RES\Workspace Manager
    Value: SelfServicePoll
    Type: REG_SZ
    Data: yes

    [32bit Windows]
    Key: HKEY_LOCAL_MACHINE\SOFTWARE\RES\Workspace Manager
    Value: SelfServicePoll
    Type: REG_SZ
    Data: yes

     

     

    Note:

    - This registry setting will work from RES ONE Workspace 2016 SR1 revision 3 (9.12.1.3) and RES ONE Workspace v10 (10.0.0.0) and higher.
    - From RES ONE Workspace 10.1.0.0 and higher, the default command is '-poll'. The registry settings is not needed anymore to force this behavior.
    - From RES ONE Workspace 10.1.400.0, the SelfServicePoll registry value can be configured to use the '-ipoll' command instead of the '-poll' command. To use the '-ipoll' command, configure the registry setting like this:


    [64bit Windows]
    Key: HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\RES\Workspace Manager

    [32bit Windows]
    Key: HKEY_LOCAL_MACHINE\SOFTWARE\RES\Workspace Manager

    Value: SelfServicePoll
    Type: REG_SZ
    Data: no

     

    Important:

    Only configure the registry setting to 'no' if the applications can't be started when single sign on isn't working. The creation of the xml file can take up to 1 minute when the '-poll' command is used.