Avalanche 6.2: Software payload not installing to device using Central File Store

Version 1

    Verified Product Versions

    Avalanche 6.2

     

     

    Scenario:

    When using Central File Store and the Android devices are not installing software payloads or file payloads. Devices are getting the message sync failed

     

    Cause:

    The following similar message could be find on the enabler logs:

     

    02-05 17:39:16.724 E/com.wavelink.android.policyenforcement.api.impl.SoftwarePolicyEnforcement( 9460): 2018-02-05 17:39:16.724 Device payload SplashtopZebraStreamer has failed to download to the device, download for reason javax.net.ssl.SSLHandshakeException: Unable to verify the server certificate.

    02-05 17:39:16.752 E/com.wavelink.android.webservices.AndroidSSLSocketFactory( 9460): 2018-02-05 17:39:16.752 checkServerTrusted failed for server: CN=10.5.85.24

    02-05 17:39:16.752 E/com.wavelink.android.policyenforcement.api.impl.SoftwarePolicyEnforcement( 9460): 2018-02-05 17:39:16.752 Error with download: javax.net.ssl.SSLHandshakeException: Unable to verify the server certificate

    02-05 17:39:16.753 E/com.wavelink.android.policyenforcement.api.impl.SoftwarePolicyEnforcement( 9460): 2018-02-05 17:39:16.752 Device payload SplashtopZebraPlatform has failed to download to the device, download for reason javax.net.ssl.SSLHandshakeException: Unable to verify the server certificate.

     

    Resolution:

    Based on the message from logs this one specifically points to a certificate error. “Unable to verify the server certificate”.

     

    Ensure that the correct valid certificate is added to the Central File Storage configuration. A certificate associated with the public address of the location of the Central File Store. If you have the Central File Store located at the same address as a Smart Device Server, you can use the same certificate for the Central File Store.