Issue: Dell USB-C Network Dongle causing Duplicate Inventory Entries

Version 7

    Verified Product Versions

    Endpoint Manager 2016.xEndpoint Manager 2017.x

    Issue

     

    When Provisioning with a Dell USB-C Network Dongle you are getting Duplicate Device ID's in your Inventory

     

    Cause

     

    The USB-C Network Dongle is designed to pass through the Internal Device MAC Address, without the correct drivers loaded into WinPE (How to add drivers to WinPE for Ivanti EPM OS Provisioning - How to add drivers to WinPE for Ivanti EPM OS Provisioning ) the device uses its own MAC Address. When loading into WinPE a mini scan runs which creates a basic Inventory entry with the USB-C Network Dongles MAC address. Then later when the device boots into Windows and the pass through begins to work the Agent is installed a second Inventory entries is created since it now has a different MAC Address.

     

    Resolution

     

    If you load the correct drivers for the USB-C Network Dongle then the pass through functionality will work within WinPE Environment.

     

    Information from Dell - The USB-C Network Dongle is designed to pass through the Device MAC Address, this only occurs if the correct drivers are loaded into the WinPE Environment

     

    Additional Information about WinPE Drivers:

     

    How To Test Drivers Compatibility Within Winpe

    How to add drivers to WinPE for Ivanti EPM OS Provisioning