Problem / Solution: System Configuration Wizard cannot connect to Database Server.

Version 3

    Environment:

    This Solution applies to all versions of Ivanti Service Manager (current version, on the date when this article is created is 2017.2)

     

    Error Message:

    Connection Failed: Error:A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections, {provider: Named Pipes, error: 40 - Could not open a connection to SQL Server)

     

    Problem:

    In System Configuration Wizard after clicking on Test Connection appears error message.

     

    Cause:

    If SQL Server is turned on, is accessible, instance name is correct and is configured to allow remote connections, such kind of error appears if SQL services are not running.

     

    Solution:

    1. Open Services.msc console on SQL Server.

    2. Find services responsible for SQL.

     

    3. Make sure that all of them are running ( in an example above some of them are not started and that was the reason of error message).

    4. Go back to machine where Ivanti Service Manager has been installed, open System Configuration Wizard and press "Test Connection" again.

     

    5. Connection successful, issue resolved.