Error "Failed to validate the version of the database. Login failed for user 'sa'." appears when trying to apply password changes for the EPM database.

Version 3

    Verified Product Versions

    Endpoint Manager 2016.xEndpoint Manager 2017.x

    Issue

    After you update the password of your EPM database and when you try to apply the changes in the console through Ivanti Configure Services, the following error pops up when you click on Apply or OK.

     

    "Failed to validate the version of the database. Login failed for user 'sa'"


    You have ensured the password is correct and the steps in the troubleshooting document have been performed.

    Cause

    A single character has been used as the password, which is allowed by SQL Server if you choose not to enforce password policy for the account, but is not allowed by EPM.

     

    Resolution

    Use a password with more than one character instead.