Ivanti Endpoint Management Agent and .NET FAQ

Version 2

    Verified Product Versions

    Endpoint Manager 2016.xEndpoint Manager 2017.x

    Description: Some time ago Microsoft .NET was included with the Ivanti Endpoint Manager (EPM) Agent installation for Windows devices. This document will help address general information and questions.

     

    FAQ:

     

    Question 1:

    What version of .NET is included with the agent on version xxxx.xx? 

     

    Answer: The easiest way to tell what version of .NET is included with the agent on a particular version of EPM is to look in the C:\Program Files\LANDesk\ManagementSuite\ldlogon folder. See the screen shot below. This is a 2017.3 core server and has .NET 4.0 and 4.5 included.

    DotNet.png

     

    Question 2:

    Can I disable .NET from installing with the agent?

     

    Answer: No. You can change the way it installs but not IF it installs. See below. It is required for certain portions of the agent to function correctly. The help documentation (portion below) provide more details:

     

    DotNet1.png

     

    Help Doc Reference on Agent Configuration for .NET:

     

    • .NET installation: When the agent is installed, you can select whether to install Microsoft .NET 4.0 on the managed device. This is a convenience that is useful for two new options that can be installed on devices: Portal Manager (the new version of Desktop Manager) and the Location Detection option (under Inventory settings), both of which require .NET 4.0. If you include either of these options in an agent configuration, select one of the following bundling options.
      • Include .NET in agent installation package: The .NET install is contained within the agent package and is always installed.
      • If .NET is not installed, download and install: .NET is not automatically installed. After the agent is installed, it checks to see whether the managed device already has .NET 4.0 installed. If it does not, the agent uses Vulscan.exe to download and install .NET 4.0. (Any earlier versions of .NET are not affected by this installation.)

     

    Question 3:

    I have applications on my client that utilize a lower version of .NET. Installing the agent causes those applications not to function correctly. Are there any other options for managing the device?

     

    Answer: The next best option would be to utilize Agentless Scanning. The following document will help with how this works.

     

    Steps to enable the agentless scanner in 2016.3 and beyond