Error "Path does not exists" for pwrgate.exe after logon to Ivanti Workspace Control

Version 3

    Problem

     

    Consider the following situation:

    • On an existing machine RES ONE Workspace is upgraded to Ivanti Workspace Control.
    • Ivanti Workspace Control is installed on a new machine.
    • User logs on to the existing/upgraded device and from that device a new session is started to new installed machine.

    During logon the following error is displayed:

     

    C:\Program Files (x86)\Ivanti\Workspace Control\pwrgate.exe

    The specified path does not exist.

    Check the path, and then try again.

     

    pwrgate error.PNG

     

    Cause

    Due to different installation paths, this error is shown while roaming or starting pass-through sessions.

    The path C:\Program Files (x86)\RES Software\Workspace Manager  is used on the upgraded machine and C:\Program Files (x86)\Ivanti\Workspace Control on the newly installed machine.

     

    Solution

    Use the same installation path on the new machine as on the existing machine.