Problem / Solution: Remote Host Connection - The provided URI scheme 'http' is invalid; expected 'https', Parameter name: via

Version 1

    Environment:

    This Solution applies to all versions of Ivanti Service Manager (current version, on the date when this article is created is 2017.3)

     

    Problem:

    Whilst creating/using Remote Host Connection (Admin UI -> Extend -> Integration Tools -> Remote Host Connection), after pressing Test Connection button, appears error message: The provided URI scheme 'http' is invalid; expected 'https', Parameter name: via

     

    Error Message:

    The provided URI scheme 'http' is invalid; expected 'https', Parameter name: via

    Reason:

    Either Application Server uses SSL, but it should not

    or

    WinRM has not been configured to listen over HTTPS.

     

    Solution:

    Option 1: Application Server uses SSL, but we want to connect without SSL.

    Solution:

    Open System Configuration Wizard, go to Other Feature Settings and deselect "Use SSL".

    Please do not forget that clicking Next will restart Ivanti Service Manager services.

     

    Option 2: WinRM has not been configured to use SSL.

    Solution:

    Open Powershell with Administrator privileges and run: Winrm enumerate winrm/config/listener

    If there is only one listener with Transport = HTTP, it means that HTTPS listener has not been configured.

     

     

    In this case please refer to: Run Program - Remote Host and create HTTPS listener.