Issue: Provisioning task failing after try 40 of 40

Version 24

    Verified Product Versions

    Endpoint Manager 9.5Endpoint Manager 9.6Endpoint Manager 2016.xEndpoint Manager 2017.x


    Note: In LANDESK Management Suite 9.6 or 2016 the software distribution architecture has been completely redesigned, and the case of templates taking a long time to start should be improved or eliminated.


    Issue

    The provisioning task is failing to load. It will attempt to load the template and retry for 40 attempts and then the job hangs and the client stays in the WinPE screen or brings back the template section window.

     

    In 2016, the LDPROVISION.LOG file in WINPE has the following error:

    “Not able to obtain a client certificate. Aborting provisioning”

     

    Logs on the core may indicate a few different errors:

     

    In prov_schedule.exe.log - This log is located in \\core\ldmain\log

    Template is not flattened, will attempt to flatten.
    Flattening  template failed.

    In provisioning.log - This log is located in \\core\ldmain\log\provisioning. 

    Unable to find the history task


    or

    Unable to find template for computer idn ###


    or

    Unable to find computer

     

    Resolutions

    Issue - Scheduler service being stopped

    • If the scheduler service is not running, provisioning jobs will not start.
    • DCOM errors can cause the scheduler service to stop.

     

    Resolution

    • Change the service to run as a Domain Administrator and start the Scheduler service. Once this is done, the provisioning task should work.
    • Reset the password for the admin account that was running the LANDesk and LANDesk1 COM+ objects. This prevents the scheduler service from failing which prevents the provisioning template from running.
    • Start the scheduler service

     

    Issue - Computer is not showing up under All Devices in the Console

    If the LANDESK Inventory Server service is stopped on the Core Server, the device will not show up in the LANDESK Console when the Mini Scan runs when WINPE loads.  If this is happening the Provisioning.log file will show the "Unable to find computer" error.

    The Inventory service is set to ignore Mini Scans which will cause new computers to not show up in All Devices in the Console and consequently prevent templates from running.

     

    • Make sure the "Ignore Mini Scans" option is set to 0 in the Advanced Settings for the Inventory service in Configure Services.
    • Start/Restart the LANDESK Inventory Server and Managed Planet Core Scan Processor services on the Core Server.

    If a provisioning task has already been assigned to the machine in question, the task will fail. If you review the provision.log file on the core you will see a line "Computer is Busy with another task {taskID}"

    1. Determine the TaskID from the log, Go to your Core and delete that task.
    2. Delete client from database
    3. PXE boot client, or run a manual inventory scan from the device
      A Manual scan can be initiated from WinPE by running X:/Windows/System32/Startnet.cmd from a command prompt
    4. Run the provisioning task

    Issue - Corrupt Template

     

    A corrupt template can prevent correct scheduling. One cause if this is if a template is imported, the drop down boxes are not filled in as they were pointing to objects from the previous core. For example, Software Distribution actions do not have a package specified. Same with Configure Agent actions. Also any actions with scripts will have this issue.  Another way to determine if your template is not configured properly is by reviewing the Provisioning.log on the core. If you see the following:

     

    INFO    PROV_SCHEDULE        8/18/2011 5:06:50 PM    : Action LANDesk.Provisioning.Business.PAction_Distribute_software
    INFO    PROV_SCHEDULE        8/18/2011 5:06:50 PM    : Got package ID 60, requesting snippet
    INFO    PROV_SCHEDULE        8/18/2011 5:06:50 PM    : Requesting snippet for packageId 60
    INFO    PROV_SCHEDULE        8/18/2011 5:06:50 PM    : Requesting SWD snippet with task IDN 2214, package ID 60
    ERROR    PROV_SCHEDULE        8/18/2011 5:06:50 PM    : Exception encountered trying to get snippet (LANDesk.ManagementSuite.SoftwareDistribution.Business.PackageNotFoundException): This package has been deleted.
    ERROR    PROV_SCHEDULE        8/18/2011 5:06:50 PM    : GetSoftwareSnippet failed

    Resolution

    • Recreate the template, or make sure that all dropdown boxes and options are configured in the template and all included templates.
    • If you are getting the error where you are unable to get the Software Snippet, you will need to go into your Provisioning Template and make sure that all software packages are available and working. Determine which package is failing and resolve the software package. Save your template and retry the provisioning task.

    Issue - Template is trying to perform an invalid action

    Error when attempting to save template - "Cannot save changes to the template . Verify that the template name you have chosen is not already used by another template. Database Error."

    Resolution

    If you are adding included templates to a main template you will want to start with adding the included templates one at a time until you find the problem template. Then address the specifics of that template and what it is doing. Try to recreate a new template that duplicates the problem template and see if you get any errors while saving the template.

     

    Example Customer Situation:

    The problem template was one that used the Update Registry action item and the Registry Operation of Import File. Because the file that was being imported was a combination of different registry export files, and remarked out descriptions had been added to the file, the template would return error: "Cannot save changes to the template . Verify that the template name you have chosen is not already used by another template. Database Error." The initial problem came from the fact that the original template did save when maybe it should not have, which caused the provisioning task to fail and the Prov_Schedule.exe.log file to show "Flattening template failed". Once we isolated the issues with the remarked out lines in the reg file and removed them, the template saved and the provisioning task worked properly.

    In the customers environment, having the remarked out comments failed, but in a test lab the customers reg file worked fine. After getting the reg file to import and save, we found that the script failed on the reg file when trying to run it. What we discovered is that in his situation, the header in the reg file that says: "Windows Registry Editor Version 5.0" was causing it to fail, but I was unable to duplicate any of his problems in my lab. This seems to be a unique situation and may or may not apply to other customers that are having the 40 of 40 retries issue.

     

    Issue - LANDesk is trying to find a provisioning task from a failed distribution

      • The provisioning log will show  "Unable to find the history task".

     

    Resolution

        1. Delete client from database
        2. PXE boot client, or run a manual inventory scan from the device
        3. Run the provisioning task

    Issue - Too many PXE Reps to update with the Provisioning information for the device

     

    If there are a large number of PXE representatives in the environment, this error will occur as the core tries to update them all with the needed information. If it cannot complete in time for the 40 retries, the task will not start. However, if you keep waiting the template may start.

     

    Resolution

    Reduce the number of PXE reps and remove all PXE Reps that are not active.

    Issue - Templates may include Distribute Software actions to packages that contain a large amount of additional files

     

    Software packages that contain a large amount of additional files will require the core to hash the files and prepare manifest files each time a new template is run.
    This can cause significant slowdown.  As an example, Microsoft Office 2013 can contain ~ 570 files if the files are included as additional files to the main setup program.
    It is recommended to package something like this into a single file or into a few files.  This should significantly speed up the distribution process.

    Due to the Software Distribution architecture changes in LDMS 9.6, this issue and most other issues with templates taking a long time to start should be eliminated.

    Resolution

     

    Issue - User cannot see the devices in the console

    The user that is selecting the template cannot see the devices in the Console that are being imaged.

     

    Resolution

    Give the user that is running the template the All Devices scope or create a scope that sees the devices and assign it to the user in the User Management tool.

     

    Issue - Task Handler Proxy crashes in Event Viewer (TaskHandlerProxy.exe.log will show unable to find user in the database as well)

    Resolution

     

    Add the account that is configured in the scheduler service into the LANDesk Administrators group and add the account into the console. Once you can see the user in the Console (in the "User Administration" module) run ResolveUserGroups.exe and CreateLandeskRights.exe as an admin from the ManagementSuite Directory. Verify that the User is configured as an LDMS Admin and then restart the scheduler service.