Problem
Consider the following scenario:
- Ivanti Workspace Control is installed on a Server or Desktop OS.
- The Citrix Receiver is installed but without the Self Service Plugin.
In this scenario, Ivanti Workspace Control process pfwsmgr.exe uses a small percentage of CPU time continuously for every user.
When looking at an Ivanti Workspace Control trace log the following trace lines are visible.
<DATE> <TIME> 216228 1 pfwsmgr 230 <UserName> ProcessHelper.CreateProcess; Executing: ["C:\Program Files (x86)\Citrix\ICA Client\SelfServicePlugin\SelfService.exe" -init -poll -exit]
<DATE> <TIME> 216228 1 pfwsmgr 230 <UserName> ProcessHelper.CreateProcess; Failed to create process (CommandLine: '"C:\Program Files (x86)\Citrix\ICA Client\SelfServicePlugin\SelfService.exe" -init -poll -exit'): 2 - The system cannot find the file specified |0|
Cause
Ivanti Workspace Control triggers SelfService.exe to generate an XML file containing Published Application information. This is done during login and session refresh.
When Selfservice.exe is not installed the error is logged and the action is attempted repeatedly.
Solution
Selfservice.exe is required for Ivanti Workspace Control when using Citrix Receiver 4.x or higher.
Workaround
The check for SelfService.exe can be disabled by configuring Ivanti Workspace Controle to use legacy publishing methods.
This is not recommended as a long-term solution though.
More information on this can be found in the following article: Error: Application can`t be started... (invalid reference)
Comments