Schedule Manager – sends automatic report mails even after deleting schedule

Version 5

    Verified Product Versions

    LANDESK Service Desk 2016.x

     

    Problem:

     

    Schedule Manager is sending reports even after deleting the schedule in Console > Administration > Schedule Manager > Report Management > Schedules

     

    Cause:

     

    IIS is still caching the old settings and hence the deletion is not yet effective.

     

    Solution:

     

    An IIS reset on the ITBM Service Desk application server. You might also require a restart of the service “Touchpaper Query Reports Engine” on the same server.

     

    Notes:

     

    The “QueryReport Service” component of the application server is responsible for sending out reports via mail and uses the windows service “Touchpaper Query Reports Engine” found in the windows services MMC. This service also has a text based config file called “Touchpaper.Service.QueryReports.WindowsService.exe.config” with the default location: C:\Program Files\LANDesk\LANDesk Applications (In 7.5 this is configured in the Configuration Centre). This config file can also be used to switch on logging for general troubleshooting.

     

    Tip:

     

    By default this service is set for a manual start and is not running. But some reason if it running or on automatic start you can stop the service and set the startup type either to manual or disabled ONLY IF you are not using the schedule manager functionality.