Screensaver does not lock system in defined couple of minutes

Version 7

    Problem

    Consider the following scenario:

     

    • Citrix XenApp 7.6 or Citrix XenDesktop 7.6 or later is used.
    • In the Ivanti Workspace Control Console, the Screensaver feature is enabled.
    • The option Turn screensaver on is enabled.
    • The option Set mandatory timeout for screensaver is configured.

     

    In this scenario, the session is not locked within the configured timeout.

     

     

    Cause

    Due to a missing registry setting the screensaver is not starting on a Citrix XenApp or Citrix XenDesktop VDA,

    This is a known Citrix issue.

    For more information see Citrix documentation on Known Issues.

     

     

    Solution

    Add the following registry value to the machine running Ivanti Workspace Control;

     

    Key: HKEY_LOCAL_MACHINE\SOFTWARE\Citrix\Graphics

    Value: SetDisplayRequiredMode

    Type: REG_DWORD

    Data: 00000000

     

    Source: Screensaver Not Working in XenDesktop