During the logoff of an Ivanti Workspace Managed session Citrix Receiver is getting a message that the connection has been interrupted

Version 3

    Problem

    Consider the following scenario:

     

    • Citrix XenApp / XenDesktop is used to provide a remote desktop session to users.
    • The VMware Hypervisor is used to distribute the Windows Operating system.
    • A user is logging off from a remote session. This might be an Ivanti Workspace Control managed session.
    • The user logs on to the remote session again.

     

    In this scenario, after the Microsoft Windows Logon, the machine can end up in a blue screen (BSOD).

    The end user will get a message from Citrix Receiver that the connection has been interrupted.

     

    Cause

    This is caused by the VMware vSphere Activity Monitoring Feature driver.
    This is a known issue affecting VMware vSphere ESXi 5.x, ESXi 6.0 and NSX 6.x.

    Solution

    Not related to Ivanti products.

     

    Follow the instructions from this VMware Knowledge Base article to resolve the issue.