Error 404 when accessing http for EMSS web console

Version 2

    Purpose

     

    Show some troubleshooting steps for error 404 when trying to access components of the EMSS web console.

     

    Symptoms

    Receiving Error 404 when accessing http://Localhost/Gravitix or http://Localhost/agentcenter/agentcenter.asmx

     

    However, https://Localhost/servicerequestrestis accessible

     

    Essentially, http is being blocked where https is not

     

    Cause

     

    This can sometimes happen when IIS extension Hardening is enabled, or firewall is blocking port 80

     

    Resolution

     

    1.       Ensure port 80 is not blocked, or if it is, add the EMSS browser locations to the whitelist

     

    2.       Look at IIS extension Hardening, the following command will allow all extensions, run in an elevated command prompt

     

    a.    C:\Windows\system32\inetsrv\appcmd.exe set config /section:requestfiltering /fileExtensions.allowunlisted:true

     

     

    Affected Product(s)

     

    EMSS