A second user session to Windows 10 is logged of immediately

Version 4

    Problem

    Consider the following scenario:

     

    • Microsoft Windows 10 is used.
    • Active Setup is enabled in the Ivanti Workspace Control Console by unchecking the option Disable Active Setup within Composition > Applications > Settings.
    • Local Microsoft Windows profiles are used.
    • A user logs on successfully to a Workspace Control managed session.
    • The user logs off and the phrase End of user session is visible in the User Event Log.
    • The user logs on for the second time.

     

    In this scenario, the user session is logged off immediately. This is even before Workspace Control is started.

     

    The following message can be found in the Windows Event Log:

     

    Log Name:      Application

    Source:        Winlogon

    Date:          <Date>

    Event ID:      4006

    Task Category: None

    Level:         Warning

    Keywords:      Classic

    User:          N/A

    Computer:      <ComputerName>

    Description:

    The Windows logon process has failed to spawn a user application. Application name: . Command line parameters: C:\Program Files (x86)\RES Software\Workspace Manager\pwrinit.exe.

     

     

    Cause

    A system environment variable that configures the compatibility layer for Windows 7 is applied by User Registry during the first session.

     

    Key: HKEY_CURRENT_USER\Environment

    Value: __COMPAT_LAYER

    Type: REG_SZ

    Data: HighDpiAware

     

    This setting is not valid for Windows 10, which leads to the erroneous behavior.

     

     

    Solution

    Remove the User Registry action, that is causing the issue, from the Windows 10 machines.