Cannot login to Xtraction with error "Object reference not set to instance of an object" or "Xtraction.Shared.Model.IApplicationRequest Xtraction.ApplicationContext.get_CurrentRequest()"

Version 4

    [Issue]

    Cannot login to Xtraction with error "Object reference not set to instance of an object" or "Xtraction.Shared.Model.IApplicationRequest Xtraction.ApplicationContext.get_CurrentRequest()" after windows updates have been run

     

    *users also may experience the following error loading the homepage without debug mode: :"An error has occurred during processing.  Please try again.  If this continues to occur, please contact the application administrator."

     

    **run Xtraction in debug mode to obtain these detailed errors How do I put the Xtraction web application in debug mode?

     

     

     

    [Cause]

    Microsoft .Net Framework 4.7.1 or above patches listed below have caused issues with the authenticating of users when logging into Xtraction

    4054566

    4338605

     

    KB4459924 for Windows Server 2012 R2 x64,

    KB4462917 for Windows Server 2016

     

     

    [Resolution]

    *Clear ASP.NET temporary folder - How to clear the Temporary ASP.NET files

     

    1. Log into the server and open IIS.

    2. Navigate to this directory, C:\Windows\Microsoft.NET\Framework64\v4.0.30319\Temporary ASP.NET Files

    3. Stop IIS.

    4. Delete all of the content in the directory above.

    5. Start IIS.

     

     

    * in the instance that this does not work, please remove the patches above and proceed to clear asp.net temp directory