Access Control causes application issues when computer LDAP path contains a forward slash "/"

Version 5

    Problem

    Consider the following scenario:

     

    • A zone is configured in Ivanti Workspace Control to point to a specific Active Directory group.
    • A computer OU path contains a slash: LDAP://CN=MACHINE,OU=Name/WithSlash,OU=level2,OU=level1,DC=domain,DC=com.

     

    In this scenario, the zone is not detected correctly and configuration that depends on this zone, will not be applied to that computer (e.g. delivering applications).

     

     

    Cause

    Everything in computer OU the path after the slash is removed and the following, incorrect, computer OU path is used by Ivanti Workspace Control: LDAP://WithSlash,OU=level2,OU=level1,DC=reslab,DC=com.

     

     

    Solution

    This issue is under investigation by Ivanti Support.

     

     

    Workaround

    Remove the slash "/" from the OU name in Active Directory and restart the Ivanti Workspace Control agent service.