Issue: Antivirus 2017 (Bitdefender engine) fails to install

Version 3

    Verified Product Versions

    Endpoint Manager 2017.xEndpoint Manager 2018.x

    Issue

     

    Antivirus 2017 (Bitdefender engine) fails to install.

     

    Cause

     

    If Antivirus fails to install on a device it leaves traces behind that will not allow subsequent installs to process properly.

     

    Resolution

    Cleaning up the traces of the failed install will allow subsequent installs to process properly.

     

    Step 1

     

    Delete the folders and all contents inside:

     

    C:\Program Files (x86)\LANDesk\LDClient\antivirus

    C:\Program Files (x86)\LANDesk\LDClient\temp_av

     

    Step 2

     

    Check the client Services for an existing Landesk(R) Antivirus Service.  It also may not exist in certain cases, this can happen and is normal.  If it does exist and the install failed it likely isn't running and will fail to start.

    In the registry delete the following key:

     

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LDAV

     

     

    You will likely need to reboot once you delete the registry key.

     

    Step 3

    Try installing Antivirus 2017 again.