Issue: Definitions Fail to Download To the Core Server

Version 12

    Verified Product Versions

    Endpoint Manager 9.5Endpoint Manager 9.6Endpoint Manager 2016.xEndpoint Manager 2017.xEndpoint Manager 2018.x

    Description

    Updates fail to download after scheduling or doing a run now task through the Download Updates tool. In this document, we will address AV definition downloads, but the principles apply to every sort of definition download.

    This document assumes that your definitions are not even attempting to download. This document will not address issues where your definitions are attempting to download, but are being blocked from downloading. In cases like that, ensure that the defintiion vendor's websites are whitelisted in your organization's security devices and that you can access the vendors' websites through the browser on your core.

     

    Troubleshooting

     

    Verify your settings

    1. Verify that you have the correct Definition types checked in the Updates tab of Download Updates. For instance, if you are trying to download the latest AV definitions, you will want to select that in the window.
    2. If it is a scheduled download task that is failing to run, go into the task and make sure that you have the Repeat every checkbox selected as by default a scheduled download will run only once.
    3. Check the Patch and Compliance tab in your task and make sure that what you want to download is listed in the Definition types and Languages. If you want to change anything in the Patch and Compliance tab, you will need to schedule a new task with your desired definition type and language selected as is shown in step 1.

     

     

    Check for a potential licensing issue

     

    1. Check the VAminer.log.detail log to see if your core thinks you have a license to download your desired definitions.
    2. In the Download Updates window, select to Download now then in the resulting screen select View log.
    3. Select the checkbox to show detailed information then navigate to the log path shown.
    4. Open the log then do a search for the word "license." It will be apparent if your core does not think that you are licensed for the product you are trying to download. You will see an error similar to the following:

    16688:LoadingPatchSources : processing: Ivanti AV 10.0

    16688:LoadingPatchSources : Skipping source 'Ivanti AV 10.0' ('/LDPM8/ldvul.php?%Credentials%KEYWORD=filename&FILENAME=Virus4_Win97') that is not licensed for feature 'LANDeskAVSubscription'

     

    You should see something similar to the following for your particular product if you are correctly licensed:

    INFO  11088:LoadingPatchSources : LANDeskAV: Valid license (Exp: 12/31/2020)

    INFO  11088:LoadingPatchSources : IvantiAVSubscription: Valid license (Exp: 12/31/2020)

     

    If you do not see a license issue and are still not able to download your desired definitions, please reach out to support. If you do see a license issue, proceed with the following steps.

     

     

    Check your license capabilities

     

    1. Open one of the following locations:
      • In the Start Menu of your system, go to Activate Ivanti Core Server > Activations > Licenses.
      • In your core, go to Configure > Product Licensing...

     

        2. Check to make sure that you have the correct license capability and the correct version. For instance, if you were using Ivanti Antivirus on a 2018.1 core, you would look for product names including "Antivirus" and Version 11.0.

     

    The version of the product name is very important. Here are the current versions:

    • 2018.3 is 11.1
    • 2018.1 is 11.0
    • 2017.3 is 10.1
    • 2016.3 is 10.0

     

        3. If everything looks correct above and the downloads are still not working or if you have the correct product name but your core's version is not in your product licensing list, please contact support. If you do not see your product name above but are sure that you have the correct license, proceed to the following steps.

     

    Address your licensing issue

     

    1. Close your core completely.
    2. Go to Program Files(or Program Files (x86))\Landesk and move or delete the contents of the Authorization Files directory.
    3. Reactivate your core.

     

    If you still are unable to download definitions after following all of the above steps, please contact support and send them your vaminer.details.log.

     

     

    Affected Products

    LDMS 2016.1

    EPM 2017.3

    EPM 2018.1