Web Access Reports Won't Open: Database Vendor Code: 17

Version 2

    Verified Product Versions

    Service Desk 2016.xService Desk 2017.x

    Problem:

    When attempting to view reports within Web Access, the following error message occurs:

     

    There has been an unexpected error.  Click Continue to return to the previous page.

    Failed to open the connection.  Details: [Database Vendor Code: 17] Failed to open the connection. IncidentManagement.Incident {xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx}.rpt Details: [Database Vendor Code: 17]

     

     

     

    Cause:

    The reports are launched directly from the web server, and are not able to access the configured database, potentially occurring for the following reasons:

    • Reports were not configured during initial installation.
    • Database server has been relocated.
    • User credentials have been changed.

     

     

    Resolution:

    In order to resolve the issue, a tool has been provided to bulk update reports.

    Please note: This tool must be run on all Web Access servers, not the application server.

     

    Determine your report location

    1. Launch the Configuration Center.
    2. Single left-click  on the desired Application, typically Service Desk.
    3. In the Configured Applications section, locate the Web Access application experiencing the issue, and click the corresponding Edit link.
    4. Save the Reports path value to your clipboard or a Notepad document.  This will be needed in the next section.

         Default Reports Folders location: C:\ProgramData\LANDesk\ServiceDesk\LANDeskServiceDesk.WebAccess\Reports

    Setting the Crystal Reports DSN

     

    1. From the ..\Program Files\LANDesk\Service Desk\Reports folder, run CrystalReportsDSNSetter.exe.
      The Set Crystal Reports DSN dialog appears.

    1. Reports Folder: Paste the contents of the clipboard or browse to the folder discovered in Step 4 of the previous section.
    2. Populate the Data Source section:
      1. Database Server should be specified as ServerName\InstanceName
      2. Please validate the username and password by logging in directly to SQL Server Management Studio.
    3. Click Run.  It is typical for the initial execution to take several minutes.  Please do not close the dialog if the application hangs as it will resume after a brief delay.
    4. In ..\Program Files\LANDesk\Service Desk\Reports, review the file named LogFile that has been created.  It lists the names of all reports on individual lines.  Any errors will be on the line following the report name.
    5. If no errors occurred, the DSNs are now set.

    Setting the Crystal Reports data source location for reports that contain subreports

    The Set Crystal Reports DSN utility does not support setting the data source location for reports that contain subreports (for example, the supplied Task.rpt). For these reports, you need to use Crystal Reports to set the data source location both for the report itself and any subreports inside the report. In Crystal Reports, from the Database menu, click Set Datasource Location. Update the Datasource Location for the report and all of the subreports.