Import from Active Directory error "Could not find Related Object User.DN"

Version 3

    Verified Product Versions

    Service Desk 7.6Service Desk 7.7.xService Desk 7.8.xService Desk 2016.xService Desk 2017.x

    [ISSUE]

    End users or analyst do not import or update. Logs will show error similar to this:

     

    9/27/2018 08:05:41 : Import Started

    9/27/2018 08:05:41 : Source count = 27

    9/27/2018 08:05:42 : Could not find Related Object User.DN = .

    9/27/2018 08:05:43 : Could not find Related Object User.DN = .

    9/27/2018 08:05:43 : Could not find Related Object User.DN = .

    9/27/2018 08:05:43 : Could not find Related Object User.DN = .

    9/27/2018 08:05:43 : Could not find Related Object User.DN = .

    9/27/2018 08:05:43 : Could not find Related Object User.DN = .

    9/27/2018 08:05:44 : Could not find Related Object User.DN = .

    9/27/2018 08:05:44 : ProcessMappings: Record = 27

    9/27/2018 08:05:44 : Import Ended

    9/27/2018 08:05:44 : This import took 00:00:02

     

     

     

    [CAUSE]

    The 2 most common reasons for this error are:

    1. The manager field on your import is mapped from AD to Service Desk and there is missing data in the Manger field for users in AD

    2. There is a LDAP filter which requires manger to be imported and there is missing data in the Manager field for users in AD

     

     

     

    [RESOLUTION]

    The manager fields in AD should have a valid Manager to import/update.

     

    *Alternatively, you can either edit your LDAP Filter to not require manager from AD or un-map the Manager field in your Import mapping so it will bypass that field.