Raise User / Config Item / Config Type Hyperlinks do not work when attribute added manually to the window

Version 1

    Config Item hyperlink does not work when attribute added manually to a newly created window or when removed from the OOTB window and then re-added again.

     

    More details:

     

    When you raise a new Incident / Problem  and select the Config Item drop down, if you have the correct modify privileges and have "show hyperlink" = true on the label you can click on the Hyperlink to open the actual Config Item record.

     

    However, if you either remove the config item attribute from the window, or create a new window from scratch then drag this on, you find that this stops working.

    • This only affects users who are not part of the Administrators role - users like SA will find that the hyperlink continues to work ok.
    • The same definitely applies for the Config Type and Raise User drop downs plus may also apply to others that you have a hyperlink on.
    • This has been seen on versions 7.2.6 and 7.3 but may also have been an (unreported) issue in earlier versions.

     

    Workaround (try on a test system first and backup before applying to live):

     

    1) First you need the handlers options in the Console.exe.config by adding the following lines into your console.exe.config (take a copy of the file first):
    <add key="ShowHandlerConfiguration" value="true" />
    <add key="ConfigureHandlers" value="true" />
    2) In window manager select the CI item / CI type / Raise User field as applicable.
    3) In the properties select he handlers option and remove the two SetLinkState Handlers from the top of the list.
    4) Then from the Related field handlers on the left, add the two set link state handlers back on (so they appear at the bottom of the list on the right) one is set to initialise and the other to value changed events.
    5) Move something on the window and move it back so that the window design change can be saved.
    6) Save the change to the window.

     

    NOTE:  Ensure that you also have the "show hyperlink" = true on the attribute label too.