Problem / Solution: How to Configure Self Service Mobile Search for Request Offering & My Items

Version 3

    Issue:

    In the ISM 2018.3.1 Release Notes (Ivanti Service Manager 2018.3.x Release Notes ) on page 6 it states:

     

    Search Results in Responsive User Interface Home Page includes Request Offerings and My Items

    In Ivanti Service Manager, with effect from version 2018.3.1, support is provided to include Request Offerings

    and My Items in the search results when search is performed from the Responsive User Interface Home page.

    And on clicking on any search result item, its respective page is displayed.

    Note: FAQs and Announcements are configured to be displayed as part of the out-of-the-box settings.

    For Request Offerings and My Items to be included, you must configure the Search Settings.

     

    We have tried to configure Search for Mobile Self Service role to use RequestOffering (ServiceReqTemplate) however when we search and then select the Offering we get an error (Cant Load Form with ID -2 not found)

     

    Please advise the correct configuration to search request offerings as stated in the release guide.

    Requires Access To:

    ISM 2018.3.1

     

    Error message:

    Cannot Load Form with ID -2 not found

     

    Cause:

    In the customer's case, the error was due to Status filter not being added, so un-published Request Offerings were returned.

     

    Solution / Workaround:

     

    To enable mobile self-service landing page search for Request Offerings and My Items, please follow the following steps:

     

    For Request Offerings:

    Go to the Admin UI (Configure Application) and select Users and Permission - Roles and Permission.

    Select the Role which has the new self service mobile UI enabled (by default this includes Admin and SelfServiceMobile.)

    Go to Top Level Tabs and select Search.

    FAQ and Announcements are already configured Out of the box.

    Add New and set Object Name to Service Request Template

    Click Edit Preview

    Set Title as Description

    Set Preview Text Field as Name

    Set Form for Hover Panel as ServiceReqTemplate.Brief.

    Save

    Click Edit Filter

    Add New and set Filter Display Name to Status

    Set Condition as $([MatchedObject]Status == "Published (Automatic)")

    Check Run By Default

    Save

    After saving the Role, open the client using the updated Role

    In the search box type the name of one of your offerings; it should give you a suggestion for the request offering and upon clicking, the related request offering should open.

     

    For MyItems, please follow the configuration steps as above, with the following settings:

    Add New and set Object Name as My Item.

    Click Edit Preview

    Set Title as Display Text

    Set Preview Text Field as Display Text

    Set Form for Hover Panel as FRS_MyItems.Brief

    After saving the Role, open the client using the updated Role

    Go to the My items workspace and note the title of any item (just to make validation a bit easier).

    Type the title into the search box of the landing page; the related items should come up in the suggestions, and upon clicking the related MyItem record should open.