.NET error when installing LDMS 9 Remote Console on Windows Vista or Server 2003

Version 4
    Problem

    Some users have seen problems with installing the LANDesk Management Console for LDMS 9 on a Windows Vista machine. The client machine will pass the prerequisite checker, but then once the installer starts, an error is presented that "The following prerequisite components are Missing: Microsoft .NET 2.0 or 3.0 must be installed". This will appear despite having .NET installed, even up to version 3.5 SP1. This will happen on any Vista or Server 2003 computers that have IIS or IIS components installed or active, but do not have the ASP.NET components installed. Normally this occurs on Vista when the client machine has Exchange management tools installed.

     

    Cause

    This appears to be caused by a conflict on the Windows Vista computer with IIS and .NET. The prerequiste checker correctly identifies Microsoft .NET installed on the machine, but the setup application checks to see if IIS is installed, it then checks to see if the ASP.NET functionality is installed on the IIS component.

     

    Resolution

    This can be resolved by installing the ASP.NET on the target computer or removing the Application Server Role. To do this, open the "Turn Windows features on or off" dialog (Control Panel -> Programs -> Programs and Features -> Turn Windows features on or off) and install the ASP.NET component (Internet Information Services -> World Wide Web Services -> Application Development Features -> ASP.NET)

     

    ASP.NET Enable - Vista.jpg

     

    Once this is installed, restart the Remote Console installation and it should complete successfully.