Error: "Value was either too large or too small for an Int32"

Version 6

    Verified Product Versions

    LANDESK Service Desk 7.7.xLANDESK Service Desk 7.8.x

    Problem:

    In administration or when adjusting the panel size you receive a "Unhandled Error" Message and in the stacktrace it says:

     

    ************** Exception Text **************
    System.OverflowException: Value was either too large or too small for an Int32.
    at System.Decimal.ToInt32(Decimal d)
    at Crownwood.DotNetMagic.Controls.TabGroupSequence.AllocateRemainingSpace(Int32[]& positions, Int32 windowSpace)
    at Crownwood.DotNetMagic.Controls.TabGroupSequence.RepositionChildren()
    at Crownwood.DotNetMagic.Controls.TabGroupSequence.OnControlResize(Object sender, EventArgs e)

     

    Cause:

    This is possibly caused by having two monitors and using Service Desk on that which is corrupting the window settings for that user in the Database

     

    Solution:

    Run the below Script after amending it with the user id of the affected user.

    Caution: Please ensure you have a fully restorable backup of your Database before running the script.


    delete from tps_application_user_setting where tps_name = 'ActionPanelConfig' and tps_user_guid = (select tps_guid from tps_user where tps_name = 'sa');

     

    Solution 2:

    In some instances this issue has been corrected by running the following:

     

    update tps_application_user_setting set tps_value = replace(cast(tps_value as nvarchar(max)), 'INF','0.71274961597542241') where tps_value like '%INF%'