Collection showing one hour behind

Version 5

    Verified Product Versions

    LANDESK Service Desk 7.6LANDESK Service Desk 7.7.xLANDESK Service Desk 7.8.xLANDESK Service Desk 2016.xLANDESK Asset Central 2016.x

    If you notice that you have a collection on your IPC that is showing one hour behind the time it's supposed to show, for example you create an Incident at 10:00, the creation date of the Incident is showing 10:00. You instantly add a Reminder to this Incident and the creation date of the Reminder is showing 09:00.

     

    This is due to the Creation Date attribute of the Reminder not having the Adjust for time Zone set to True in Object Designer. This option when looking at it in Object Designer will however be greyed out. Here is how to set it to True.

     

     

    Please make sure that this is done out of hours when everyone is logged out from the system and that a fully restorable copy of your database has been taken.

     


    1. Run this script towards the database: (You do NOT need to modify this)
    -----------------
    -- Script to revert is_readonly flag on CreateDate/UpdateDate attributes that
    -- are not appearing in the Time Zone Adjuster tool for conversion to UTC.

     

    update md_attribute_type set md_is_readonly = 0
    where md_is_readonly = 1 and md_data_type = 3 
    and md_persistence_flags in (4,128) 
    and md_defined_by = 2 and md_adjust_for_tz = 0 
    


    -----------------

     

    2. Do an IISReset.
    3. Run the "Touchpaper.Tools.TZAdjuster.exe" tool which you will find in the following path: C:\\Inetpub\wwwroot\Touchpaper.Framework.Web\bin"

    From version 7.5 this is located in:

    \Program Files (x86)\LANDesk\Service Desk\WebApp\Framework\Bin\

     

    You will need to connet the tool to your tps.

    In the list you get up you will find the relevant attribute and can choose to update this to be adjustable for time zone.

    In the drop down list above the list box, please select your current time zone.

     

    PLEASE NOTE, only select the relevant attribute and NOT all of the attributes as some shouldn't be set for this.