5 Replies Latest reply on Jan 12, 2015 6:52 AM by JonnyB

    Remote devices are not reporting to the Core.


      I recently sent out instructions for Agent installation/update along with a self contained agent to my remote users. Now some remote devices are unable to run an inventory scan. They show up on the On-Demand (Waiting HTML Agents) page but do not show up under All Devices on the core.


      Has anyone experienced this?

        • 1. Re: Remote devices are not reporting to the Core.

          Hi there,

          This can be due to the fact that the inventory scan need the client certificate to be present on the managed device.


          I assume you followed the instructions about how to automate this process. If not, here is the related article:

          How to Perform an Unattended configuration of the client for the Cloud Services Appliance


          Then, to troubleshoot the inventory scan process, I would start from this very detailed step by step article:
          How To Troubleshoot Brokerconfig and General Gateway Agent Issues


          Last, I would check if the devices are actually sending the inventory to the core but the problem is while processing the inventory data. Can you check if you have any error message in the application event log on the core when the client sends its data?


          Let me know if this helps you solving your issue

          • 2. Re: Remote devices are not reporting to the Core.

            Thanks for your prompt response Francesco.


            I didn't follow the instructions in the first link because the first time I saw that link, I passed on because of the disclaimer but since that's your recommendation, I will get back to it if every other thing fails


            Few things to note here:


            A number of these remote clients already checked in on the Core during the first inventory scan that's performed during agent installation. Now some other remote devices show up on the CSA Waiting HTML Agents page but still never show up on the core. All remote users received the same self-contained agent exe.


            Through my troubleshooting, I checked the certificates on the good and bad. and saw some old certificates from the previous LD 9.0 Core that's been decommissioned a while ago. Once I deleted the rogue certificate, I attempted a successful inventory scan on that one client but it would be time consuming to do this for all the other bad remote clients.


            I am going through the second link and I will provide updates asap.


            Thank you very much! LD tech support hasn't been helpful at all for any of my previous tickets.

            • 3. Re: Remote devices are not reporting to the Core.

              Just to clarify how the clients work outside the CSA, if you install a standard LANDESK Agent on a device, and then place it outside the appliance, this won't be able to run an inventory scan.

              What is needed is to install the client certificate on the managed node.


              This operation can be done in a few ways:


              1) Manually running brokerconfig.exe on the managed device

              2) Running the script "Create Management Gateway Client Certificate" you can find in the Management Console (this works only on the clients connected inside the CSA though)

              3) Using the link posted in the previous comment


              The third method retrieves the certificate after the agent installation, during its first inventory scan.

              Once the client received the certificate, you should find the related files in %LDMS_LOCAL_DIR%\..\..\Shared Files\cbaroot\broker


              These files are:





              Without these files a client connected outside the CSA won't be able to run an inventory scan.


              Last, the forum is a space where LANDESK Users communicate, share ideas and help each other, so in case you need the full technical support service, you can contact us starting from https://support.landesk.com. This will require your company to have a support program active with LANDESK.


              Hope this helps

              • 4. Re: Remote devices are not reporting to the Core.



                Here's my scenario:


                Yea, the Self-contained exe was created from the standard agent and distributed to remote clients.


                Now the remote clients previously had an old agent plus cert from the old Core which caused the agents to remain in Direct mode when taken off the internal network. I figured this out while going through the step by step instructions for the CSA cos support never got back to me with a solution (hence my previous comment). Turns out that after deleting the old cert (@ %LDMS_LOCAL_DIR%\Shared Files\cbaroot\certs) the agent immediately switched to gateway mode. I went on to delete the items in the broker folder prior to installing the agent on a remote machine and the device showed up immediately on my Core.


                Now your brilliant response (much appreciated) still doesn't address the fact that some devices show up on the core while others don't.


                I have just checked the files you mentioned on my machine and I am setting up 2 computers to test the agent installation off-net just like my remote users. I will get back to you with my findings asap.


                PS: I really appreciate your time and assistance. I am just new to LD and I want to learn as much from every issue I experience.

                • 5. Re: Remote devices are not reporting to the Core.
                  JonnyB SupportEmployee

                  Were you able to get this worked out?