5 Replies Latest reply on Jun 30, 2015 4:53 PM by MrGadget

    Inject Script Error - Logs Attached


      I am having an issue trying to get a new template to run.  It seems to fail at "Inject Script", and it looks like that is due to there being no C:\ to move the file to.  I'm not sure why it's not working, but I did copy the following logs : ldProvisioning.log - InjectScript.log, and diskpart.txt.  The thing that really baffles me is that it works sometimes.  I had the template working, then I pointed it to a test TBI and it failed.  So I then reverted the template back the original TBI that worked, and now that is failing as well, all with the same error! 


      We currently have multiple templates that work fine, and I originally was making a private copy of of one of them, and then removing most of the System Configuration steps, leaving just a basic provisioning of the image, the LD agent, patches, and a reboot.  That is when it started failing.  So I decided to try and build a brand new template to avoid any clone issues, and at first it worked...but then once I pointed to a different TBI, it failed, and keeps failing if I revert back.  I know pointing to a different template is not the cause, as that is how we update our base image.  Once testing is completed, we simply replace the TBI in our production folder, and we never see that error.





        • 1. Re: Inject Script Error - Logs Attached

          Rsteele77, can you attach your template to the thread?

          • 2. Re: Inject Script Error - Logs Attached

            Update to this issue.  I've been able to make it work by adding in a template action, "Mount Partition", directly before the "Inject Script" acton.  I'm not sure if one of the 30+ patches installed to the base image caused the issue, but this is the only way I've been able to make it work.  We have a 3rd party LANDesk consultant here helping us build our LD 9.6 environment, and he couldn't figure out why this happened either.  The action directly before "Mount Partition" is "Set Active", which is what we used to make the drive bootable in previous images.  I'm not sure what changed, but using the "Mount Partition" is the only thing that seemed to work.  I'm being allowed to make a change to our template structure with that addition, only because we are migrating to LD 9.6 shortly and have to rebuild templates anyway.

            • 3. Re: Inject Script Error - Logs Attached
              Markus.Gonser ITSMMVPGroup

              Hi RSteele77,

              like LANDnate, it is very helpfull if you upload your os template.


              best regards


              • 4. Re: Inject Script Error - Logs Attached

                Attached is the template as requested.  If you can figure it out, great.  If not, I'll have to stick with that extra "Mount Partition" action, because that seems to work for now, albeit we will have to update each of our 14 templates..  But being able to preserve our existing templates without making changes would be nice...

                • 5. Re: Inject Script Error - Logs Attached
                  MrGadget Expert

                  None of what you say makes logical sense. I'll just tell you some of the things I ran in to.

                  1. Made a change to an existing template. It started failing but not at the section I made a change to. Had to completely make a new one. (This happens a lot with us.)

                  2. I believe in 9.5 there was a change in a SP update that caused all of our templates to fail at inject script because there was either the wrong partition named c: or there was no c: volume letter. Had to ad the mount partition.

                  Have you upgraded your service pack to get ready for the 9.6 upgrade?

                  Take out the Mount partition and put a wait in your template before the inject script and see what your "only 1 partition" is labeled. Note: from what I could tell you only have 1 partition.