9 Replies Latest reply on Aug 8, 2016 11:33 AM by phoffmann

    MERGE.INI not working

    ecoidan Specialist

      LDMS 9.6 SP1

      LDMS 9.6 SP2.


      I am not able to get the merge.ini to import into the ntstacfg.in#. Last time it worked was 9.5 SP2. I have been manually adding my custom entries to the ntstacfg.in# and running stamper but as I apply service packs and sustained patches the ntstacfg.in# is replaced and I lose all my custom settings. I have 6 core servers that this fails on. Some have Windows 2008 R2 and others are Windows 2012 R2. Some have been upgraded from LDMS 9.5 and other are clean new builds of 9.6. Merge.ini no longer works in LDMS 9.6 SP1 and SP2.


      Anyone else notice this?  Anyone else still use this feature? <GRIN>

        • 1. Re: MERGE.INI not working

          Most parts of the .ini has been moved to Reporting / Monitoring > Manage Software list > settings

          • 2. Re: MERGE.INI not working
            ecoidan Specialist

            That function hasn't been moved to Manage Software list.  I cant even find any reference to MERGE on the community anymore either.

            • 3. Re: MERGE.INI not working
              phoffmann SupportEmployee

              [Edit: - the information in this thread has been formalised a bit better in this article here - MERGEINI - What is it and how to use it ]


              So - a couple of things here.


              1 - Only stumbled over this thread by accident, so apologies for any delayed response.


              2 - Merge.ini functionality is *NOT* related to the "Manage Software List" functionality. So whilst "MOST" functionality has been hauled into there, the MERGEINI stuff has NOT!


              3 - Mergi.ini still works just fine with 9.6 -- I'll write up a clean article on it with screenshots & a working example, but here's something to go on, via a point-by-point basis.




              I - Create your customised INI-file. Let's call it "MyCustom.ini" and save it in the LDLOGON directory on the core (by default -- "C:\Program Files\LANDesk\ManagementSuite\ldlogon\").

              II - Add / edit the contents of your customised INI file. So for arguments' sake, let's include a logo bitmap in the CBA post copy actions. So the contents would be:


              [Common Base Agent Post Copy]

              FILE25000=MyBitmap.bmp, MyBitmap.bmp, NOCOPYERROR



              III - Now, launch regedit (on the Core) and go to:



              NOTE: Chances are the "Files" key does not exist, so you'll need to create it. It isn't there by default.


              IV - Create a STRING entry (name it whatever you want), and as the value, point it to the full path of your customised INI-file. Because the odds are that you'll be dealing with spaces somewhere along the line, it'd be a good idea to use quotes on either end. So in my example we have:

              ==> STRING called "MyCustomIni"

              ==> String value as follows:


              "C:\Program Files\LANDesk\ManagementSuite\ldlogon\MyCustom.ini"



              V - Restart the inventory service on the Core, so that it re-runs STAMPER.EXE.

              NOTE: If you open the "NTSTACFG.IN#" file in the LDLOGON directory, you should see your relevant entry updates. So in my case, we have:


              [Common Base Agent Post Copy]

              (XP, VISTA)EXEC900=%DEST%\fwregister.exe, "LANDesk Ping Discovery Service" "%SYSTEM%\cba\pds.exe", NOWINDOW

              (XP, VISTA)EXEC901=%DEST%\fwregister.exe, "LANDesk Message Service" "%SYSTEM%\msgsys.exe", NOWINDOW

              (... skipping regular stuff as it's not really relevant here...)

              EXEC20000=sc.exe, failure CBA8 reset= 86400 actions= restart/5000, NOWINDOW

              FILE25000=MyBitmap.bmp, MyBitmap.bmp, NOCOPYERROR



              The NTSTACFG.IN# and .INI files are the template files, upon which all agent configuration files are then built upon. It's important that you have those entries here.


              VI - (Re-)create / (Re-)build your agent configuration (or create a new one). Or use the "Rebuild all" button.

              This should then include your relevant entry/entries to your agent config ini files & you should be cooking with fire.




              Now then - a couple of notes / gotchas:

              * The NUMERAL (so "25000") is something that *MUST* be a unique value.

              * The numerals do *NOT* have to be sequential. So you could have "55000" followed by a "60000" just fine.

              * Because of the required uniqueness, I'd recommend starting high (say - 50000) and go from there. Better to err on the side of caution.


              That should help along I hope .

              • 4. Re: MERGE.INI not working
                phoffmann SupportEmployee

                Quick thought ... I wonder whether the reason that you think MERGEINI does not / did not work for you in 9.6 (since I infer that you used it before - with 9.5 for instance) - could be purely down to paths in the registry.


                Remember that 9.5 was still running as a 32-bit app on a 64-bit OS, so the registry path would be:

                - HKLM\SOFTWARE\Wow6432Node\LANDesk\ManagementSuite\Stamping\Files\


                In comparison, 9.6 is running a 64-bit natively, so the relevant registry path is:

                - HKLM\SOFTWARE\LANDesk\ManagementSuite\Stamping\Files\


                ... is it possible that this is the main thing that caught you out?


                Hope this helps.

                - Paul Hoffmann

                • 5. Re: MERGE.INI not working
                  ecoidan Specialist

                  I have several core servers that worked without issue.  When I was putting a new core together at a customer site the I could not get the INI info to import into the ntstacfg.in# no matter what I did. At that time we just installed SP2 on the core and I was wondering if that feature(merge.ini) was removed.  Two days later I noticed the content of my custom INI was now imported in the ntstacfg.in# and had no idea why it started working. I chalked it all up to solar flares and haven't had issues with it since.

                  • 6. Re: MERGE.INI not working
                    phoffmann SupportEmployee

                    Sounds reasonable .


                    We've all had our IT Gremlins at different times. I'll mark this question as solved then & will try to write up a cleaned-up / focussed article on MERGEINI so that anyone who wants "just that bit of information" has a gentle walkthrough through it ... no worries .

                    • 7. Re: MERGE.INI not working
                      ecoidan Specialist

                      Sooooo, lets say I want to remove all the custom file and registry entries.


                      - Removed registry entry under HKLM\SOFTWARE\LANDesk\ManagementSuite\Stamping\Files\

                      - Removed CUSTOM.INI file from LDLOGON Folder

                      - Restarted Inventory Service Twice so far

                      - Reboot Core


                      The custom entries still exist in the NTSTACFG.IN#  


                      Should I just edit the NTSTACFG.IN# directly and remove the the custom entries or am I just missing a step.

                      • 8. Re: MERGE.INI not working
                        phoffmann SupportEmployee

                        Someone edited the wrong file(s).


                        The NTSTACFG file(s) are the "blueprint" from which the actual agent-configuration INI files are created. So if you put something into the NTSTACFG, then it'll be hard-coded into any agent-configuration .INI file as well.


                        Problem with editing the NTSTACFG's is that they usually tend to get overwritten with service packs and/or new releases.


                        So - nothing is broken. Makes perfect sense that your changes in the NTSTACFG are still in the agent-config's INI file because you're not using / following the MERGEINI process .


                        Editing the NTSTACFG is essentially the "more brute force" (albeit - vulnerable to changes from updates, as indicated earlier) way to achieve the same goal.


                        Does that make sense?



                        • The "NTSTACFG.IN#" is the "template of templates" - that's what's used to create the "NTSTACFG.INI" when stamper.exe is run.
                        • ... so it makes perfect sense that any changes you do THERE would remain (the MERGEINI process doesn't even know about the NTSTACFG.IN# -- your changes have been done at a level (well - technically 2) before MERGEINI would get involved).


                        ... those aren't "wrong" places to add those changes to. But they're not places that MERGEINI adds its stuff to.

                        • 9. Re: MERGE.INI not working
                          phoffmann SupportEmployee

                          ... also - I've documented & explained the use of this over here (which may be a more readable format for folks who stumble across this thread):

                          - MERGEINI - What is it and how to use it