6 Replies Latest reply on May 19, 2016 7:02 AM by eric.willard

    HII and the 20FC Lenovo X1 Carbon

    eric.willard Rookie

      Hi All,


      I recently received a batch of 4Th Generation X1 Carbon's (20FC). Great, right? Not so much. I went out and got the SCCM driver package from SCCM Package for Windows 7 (32-bit, 64-bit) - ThinkPad X1 Yoga (Type: 20FQ, 20FR), X1 Carbon (Type 20FB, 20FC) - Lenovo …

      and I dumped the drivers into my HII library, updated the library and the PXE reps, and figured I'd be off to the races. Again, not so much. HII worked flawlessly with the Gen3 SCCM drivers, but has been nothing short of a colossal CF with the Gen 4's. The first issue I ran into was the usual "Find the obscure Windows 8 driver for the new Ethernet dongle " debacle. Fine, did that. After that was fixed, the image was dropped, and the first HII pass concludes with no issue. Drivers appear to install without error and the CTOS phase hands over to Windows. Windows then proceeds to install device drivers up to 98% where it bluescreens 100% of the time, referencing iusb3xhc.sys. This is the Intel USB 3.0 driver. I went out and found a more recent version of the driver, and that bluescreened 100% of the time as well. Odd, because with the Gen3 drivers I had no issue. So I simply removed the Gen4 USB3 driver from my driver library and used the Gen3,, and even though the driver didn't work on the Gen 4's, it did stop the bluescreening. So Once I get into Windows I checked device manager and find that The Bluetooth device adapter is not installed, the video card is not installed and then listed under "Other devices" I see "Base System Device" "Intel_Sensor_00" and "Intel_Sensor_01" all with no associated drivers. After looking at Hardware ID's I was able to determine that the underlying issue was the intel chipset driver. I had to manually install the chipset driver before any of the other devices would install. Even using the Lenovo system updater failed to install the missing drivers until the chipset had installed.


      The strange thing is that the chipset driver is included in the SCCM driver package and I can see it install during the initial HII pass, but when all is said and done after a Windows PE HII pass and a Windows 7 HII pass, the chipset driver still doesn't install properly. Has anyone had any success with these 4th generation X1 Carbons? Any feedback here is appreciated.