13 Replies Latest reply on Nov 19, 2008 9:04 PM by jmichno

    OSD issues with Laptop Image


      I was hopeing someone could give me some insight on where to look or how to fix this issue.

      I am trying to pull down my image for a Lenovo T61.  I was able to upload it fine, and I can boot to my PXE menu fine.

      For some reason the process just stalls, and I have no idea why.


      LDMS = 8.8 SP1 not quite ready for SP2


      Log of failed OSD job

      "001FE216591E","OK",0,0:00:00,9/18/2008 9:14:31 PM,9/18/2008 9:14:31 PM,"WINPE, TIMEOUT=1800"
      "001FE216591E","OK",5,0:00:02,9/18/2008 9:14:31 PM,9/18/2008 9:14:33 PM,"diskpart /s X:\LDClient\rmvol.txt"
      "001FE216591E","OK",230227968,0:04:34,9/18/2008 9:14:33 PM,9/18/2008 9:19:07 PM,"drvmap.exe domain\username 20A06EF123D596831D0C9D34756ECAA9D0311663926 I: <qt/>\\<server>\images$<qt/>, STATUS FACILITY=3513"
      "001FE216591E","OK",230227968,0:04:03,9/18/2008 9:19:07 PM,9/18/2008 9:23:10 PM,"drvmap.exe domain\username 20A06EF123D596831D0C9D34756ECAA9D0311663926 H: <qt/>\\<server>\LDMain<qt/>, STATUS FACILITY=3513"
      "001FE216591E","OK",4,0:00:01,9/18/2008 9:23:10 PM,9/18/2008 9:23:11 PM,"diskpart /s X:\LDClient\wipeDisk0.txt"
      "001FE216591E","OK",1,0:00:01,9/18/2008 9:23:11 PM,9/18/2008 9:23:12 PM,"cmd /c format /Y /FS:NTFS /Q /V:C-DRIVE c:"
      "001FE216591E","OK",230031360,0:00:01,9/18/2008 9:23:12 PM,9/18/2008 9:23:13 PM,"RunBatch -1 h:\osd\imaging restall.bat 0 i:\Laptops\T61\T61, STATUS FACILITY=3510, SYNC"
      "001FE216591E","OK",0,0:00:01,9/18/2008 9:23:13 PM,9/18/2008 9:23:14 PM,"sdclient /f /o /dest="X:\LDClient\diskinfo.exe" /p="http://<serverIP>/landesk/files/diskinfo.exe", STATUS"
      "001FE216591E","OK",0,0:00:01,9/18/2008 9:23:14 PM,9/18/2008 9:23:15 PM,"sdclient /f /o /dest="X:\LDClient\assvol.txt" /p="http://<serverIP>/landesk/files/assvol.txt", STATUS"
      "001FE216591E","OK",0,0:00:01,9/18/2008 9:23:15 PM,9/18/2008 9:23:16 PM,"tokreplw X:\LDClient\assvol.txt partition=1"
      "001FE216591E","OK",4,0:00:05,9/18/2008 9:23:16 PM,9/18/2008 9:23:21 PM,"diskpart /s X:\LDClient\assvol.txt"
      "001FE216591E","ERR_Fail",-2147024893,0:00:00,9/18/2008 9:23:21 PM,9/18/2008 9:23:21 PM,"sdclient /f /o /dest="C:\sysprep\sysprep.inf" /p="http://<serverIP>/landesk/files/Deploy%20Laptop%20T61.inf", STATUS"
      ; "Job Complete","0 Done","1 Failed","0 Off","0 Unknown"


      I thought there might have been an issue with the last line, but http://<serverIP>/landesk/files/Deploy%20Laptop%20T61.inf pulls fine from what I can tell.


      The laptop does have a SATA HDD, but I am running in compatibility mode, and the NIC drivers let me boot to PXE, and load the WinPE image.  Plus it later maps the drives it needs.


      Thanks always,


        • 1. Re: OSD issues with Laptop Image
          technobabble Apprentice

          Please remark out (;) the last line of your OSD deployment script. Then deploy the image again to the machine.When the deployment script completes. You will be able to open a command prompt and see if you can access drive C. If not, then either C drive (partition 1) was not set active or the image did not deploy properly. If you suspect that partiton 1 was not set active, you should be able to do so by running diskpart manually on the machine.


          To use Diskpart to set the partion active on the target machine:


          1. Select Go-Command Prompt

          2. Enter Diskpart at the command prompt

          3/ Enter "select disk 0" and press enter

          4. Enter "select partition 1" and press enter

          5. Enter active and press enter

          6. Enter "assign" and press enter

          7. Enter "exit" and press enter


          These steps will set partition 1 active and assign it as drive C. Which, at this point, you should to be able to enter "C:" and press enter to access the local hard drive. If you are not able to do this then run diskpart again and check to see how thge disk is setup.

          • 2. Re: OSD issues with Laptop Image

            Hey Chuck, thanks for the help...

            I followed your directions, and remarked out the last line, preventing the reboot.


            I opened a new console, and was unable to go to the c: partition.


            I then entered:


            select disk 0

            select partition 1





            I then tried to switch to the c: partition, and received this message:

            The volume does not contain a recognized file system.

            Please make sure that all required file system drivers are loaded and that the volume is not corrupted.



            • 3. Re: OSD issues with Laptop Image
              technobabble Apprentice

              If you can get to drive C after the image is deployed, then the partiton was created successfully. Go to drive C and then change to the C:\sysprep directory. If the directory doesn't exist, then, of courese, the OSD deployment script will fail at the line where it is attempting to inject the .inf file.

              • 4. Re: OSD issues with Laptop Image

                The problem is the image never deploys, probably because I can't get to the C drive.


                other ideas

                • 5. Re: OSD issues with Laptop Image
                  MarXtar ITSMMVPGroup

                  That won't be it.  The image is applied without there ever being a C: drive.  A C: drive can only be assigned if there is a valid partition and that can only be accessed if it is a valid format.


                  Have you tried running the image tool manually and restoring the image?


                  Mark Star - MarXtar LANDesk Enhancements

                  Home of Power State Notifier & Wake-On-WAN for LANDesk

                  • 6. Re: OSD issues with Laptop Image
                    technobabble Apprentice

                    I did my Lenovo T61 about a month ago but I had the SATA drivers loaded. I agree with MaxTar. Boot the machine into Windpws PE, map a drive to you images and imaging utility, and the try too deploy the image manually. It may be that WinPE is not seeing the hard drive because even in compatability mode, you still need to load the SATA drivers.


                    As I stated, I did mine but in SATA mode with the SATA drivers loaded.

                    • 7. Re: OSD issues with Laptop Image

                      So, this last go round the drives did not map.  So, I am not sure how I would manually restore the image.  I have included my OSD script to see if maybe the porblem is obvious to someone a little more advanced than I.


                      ScriptName=Deploy Laptop T61
                      ScriptDescription=Deploy Laptop T61 image

                      ImageToolCmd=RunBatch -1 h:\osd\imaging restall.bat 0 i:\Laptops\T61\T61, STATUS FACILITY=3510, SYNC
                      ImageToolCmdsFile=\\<server>\LDMAIN\LANDESK\FILES\Deploy Laptop T61.txt
                      ExistingSysPrepFile=\\<server>\LDMain\landesk\files\Deploy T61.inf
                      SysPrepFile=\\<server>\LDMAIN\LANDESK\FILES\Deploy Laptop T61.inf



                      I also have others sections:




                      But it seems to be messing up way before this.

                      • 8. Re: OSD issues with Laptop Image
                        MarXtar ITSMMVPGroup

                        If the drives are not mapping then you need to focus on that because the imaging can't take place unless it can actually get to the tool and the image using the locations you have specified in this script.


                        What happens if you manually try to map those drives, do you see errors?


                        Mark Star - MarXtar LANDesk Enhancements

                        Home of Power State Notifier & Wake-On-WAN for LANDesk

                        • 9. Re: OSD issues with Laptop Image
                          technobabble Apprentice

                          Check to see if you have an IP address assigned. If so. Try to ping your image server by name. If that does not work, then you have a DNS issue. However, you should still be able to map a drive by IP address.


                          net use i: \\\images /u:\Administrator password

                          • 10. Re: OSD issues with Laptop Image

                            thanks so much guys...

                            I'll try it this weekend, I gotta come in anyway.

                            I'll let you know.,  I rememeber seeing a doc about injecting the sata drivers, plus I'll try the net use method as well...


                            If Net use works, what should I type to manually start my restore?

                            • 11. Re: OSD issues with Laptop Image
                              MarXtar ITSMMVPGroup

                              Just browse to the drive mapped for your image tool and launch the executable.  It has a user interface that you can use to then point to your image.


                              Mark Star - MarXtar LANDesk Enhancements

                              Home of Power State Notifier & Wake-On-WAN for LANDesk

                              1 of 1 people found this helpful
                              • 12. Re: OSD issues with Laptop Image
                                technobabble Apprentice

                                Imagew.exe is LANDesk's imaging utility.

                                • 13. Re: OSD issues with Laptop Image

                                  Thanks for all the advise.


                                  Ultimately the case was this:

                                  I had copied my ini file from another script that was working fine.

                                  I thought I had everything accurately changed to represent to new image, but the old image had two partitions and the new only had one.  That is why it was freezing.


                                  To make matters worse, we have a trusted access type product installed on our network.  This has not been tuned to allow LANDesk OSD to work, although we thought it was.  Once I fixed the oversight about the  partitions, and moved into the lab, it worked fine.


                                  The only issue I now have is for some reason, the serial port and lpt1 port drivers cannot be installed. I have updated the chipset and everything.  Not sure what is up there.


                                  Thanks again for everyones help.