8 Replies Latest reply on Aug 11, 2016 12:46 PM by j0s3pha

    Layout error for CI

    stapletj@tbh.net Apprentice

      When I try to open a Laptop from the CI tab, it freezes at "Preparing Form"

       

      When I go to edit the CI layout, I get this error message:

      List Name is not defined for 'CI.Laptop' child panel of 'Laptop'.

       

      Where do I define a List Name?

        • 1. Re: Layout error for CI
          j0s3pha Apprentice

          Hello Jay,

           

          To answer your question at face value there is a pick list under configure application --> build --> pick lists --> pick list:CI Type. In there are all the different types of CIs. Examples would be server, virtual server, workstation, router, switch, batch, etc. So if you are looking at the fields for the BO of CI and you find a field named CITypeList you can see where that list comes from. I have given you a screen shot of our install and the pick list is called CI Type. You can then look at the values, either from here or by looking in the pick list section on the left pane.

           

           

          Pick List

           

           

            Validated

           

           

          Pick List Name:

           

          CI Type

           

            Is State Transition

           

           

          Each one of those does point back to a child business object off the main business object of CI. What I mean by that is if you do a search on the keyword server in the find box in your Business Object view. The first two hits you get should be CI.server and CI.virtualserver. Those are extended child CIs off the parent of CI.

           

          Now, having said all of that I have never see a CI type of laptop or a BO named CI.Laptop, did you all create a CI for this? That is possible and we have done a few. Could you actually follow what I said in the above section and verify if that type does exist in BO and the Pick lists?

           

          Thanks,

          Joe

          1 of 1 people found this helpful
          • 2. Re: Layout error for CI
            stapletj@tbh.net Apprentice

            There was no Laptop in the CI Type pick list, but there is a CI.Laptop BO

            I added it to the list, and the error message went away - Thanks!

             

            Unfortunately, it still spins at "Preparing Form" whenever I open a laptop CI from the grid, but only if it's the first CI type I try to open in the tab.

             

            I have inherited this system, so I'm not sure what level of customization has happened.

            • 3. Re: Layout error for CI
              j0s3pha Apprentice

              Jay,

               

              It sounds like there still is something missing with your BO for ci.laptop, when you go into the BO and you look at forms is there one present? Was it done manually or auto generated?

               

              I am curious if that is why it works when you load another CI cause they are all extended of the parent CI so something is turned on that doesn't stop CI.laptop, as you said if you attempt to load CI.laptop first it just spins.

               

              Thanks,

              Joe

              • 4. Re: Layout error for CI
                j0s3pha Apprentice

                Jay,

                 

                Would you mind looking in the details tab of BI CI.Laptop and verifying this is set:

                 

                Extension To:CI

                 

                Also do you have a form and layout present?

                 

                Thanks,

                Joe

                1 of 1 people found this helpful
                • 5. Re: Layout error for CI
                  stapletj@tbh.net Apprentice

                  I have 7 forms. There are two layouts - both of which say they are not used at the moment.

                  CI.Laptop - Business Object

                   

                   

                   

                  Extension To:

                   

                  CI

                   

                  Suffix Name:

                   

                  Laptop

                   

                  Display Name:

                   

                  Laptop

                   

                  Description:

                   

                  not set

                   

                  Default Form:

                   

                  CI.LaptopDetails

                  • 6. Re: Layout error for CI
                    stapletj@tbh.net Apprentice

                    I have built forms, also have autogenerated ones. I've tried switching to a basic form that just displays the name, but that doesn't help.

                    • 7. Re: Layout error for CI
                      stapletj@tbh.net Apprentice

                      This is also happening for my CI.WirelessCart BO.

                      I opened the main form, and deleted all but one of the controls, then tried deleting all of the controls so it's just blank. It still spins if I open it first, so I suspect it's not the form.

                      • 8. Re: Layout error for CI
                        j0s3pha Apprentice

                        Jay,

                         

                        I'll have to poke around more, but you definitely have an interesting problem.

                         

                        Joe