9 Replies Latest reply on Jun 24, 2009 2:53 AM by bombars

    Sysprep not applying during OSD








      We are experiencing an issue when deploying images to devices. After we have captured our base image, we create a new OS deployment task and include the sysprep.inf template file we have created which include licence details etc. The sysprep.inf settings do not apply to the target machine when the OS is deployed.


      When we initially sysprep the machine we have tried capturing the image with a completed sysprep.inf answer file in the C:\sysprep folder and having a near blank one and both have the same problem of the sysprep.inf from the LANDesk OSD task not applying. When the image was captured we selected mini-setup, detect plug and play drivers and reseal. We have also tried filling out the sysprep options section of the OSD but to no avail.


      Any ideas on what we might be missing here?





        • 1. Re: Sysprep not applying during OSD

          Which Management Suite version are you using? Are you using WinPE or DOS? Can you post your OSD script + log? What does the target machine do on first boot, does it run mini-setup at all?


          "we have tried capturing the image with a completed sysprep.inf answer file in the C:\sysprep folder and having a near blank one" - what the sysprep.inf in your image looks like is irrelevant because the OSD script is will overwrite it - except, that is exactly what you say is not happening...

          • 2. Re: Sysprep not applying during OSD

            We are using version 8.8 SP2 and this is in WinPE..... The target machine runs mini-setup,  and when i deploy the image with the attached sysprep.inf it doesn't "answer" the GUI questions.


            I have attahed the requested files. Sysprep.inf is very basic version due to the issues we are experiencin.

            • 3. Re: Sysprep not applying during OSD

              The last line in the log shows a ghost that failed. That's of course the reason why the expected sysprep.inf handling doesn't happen.


              Is this is a log of a session whereby the target rebooted into mini-setup? If so, then obviously ghost was successful enough that it restored the image and left the machine in a bootable state. But still, it failed. And the rest of the OSD script, including the lines that take care of sysprep.inf, never happened.


              Again, if what we are seeing is a log of a session that ended up rebooting the target machine into mini-setup, then what must have happened is the OSD script launched ghost, ghost restored the image but somehow crashed near the end and the machine rebooted.


              If my reading of events is correct, then you need to find out what made the machine reboot during the ghost session.

              • 4. Re: Sysprep not applying during OSD

                Okay... The ghost image completes and the machine re-boots to complete mini-setup. Is this not right? I am assuming something is not happening between the completion of the image deployment and the reboot to mini-setup. Is this when the sysprep file is copied down from the core?

                • 5. Re: Sysprep not applying during OSD

                  What should happen is the ghost image completes, the script goes on to run some post-imaging commands (including copying sysprep.inf) and only then reboots the machine into mini-setup...


                  Have a look at your OSD script (the ini file that you get when you right-click the script and do an "advanced edit"). Unless somebody has drastically trimmed it down, the image restore is not the end of an OSD script. Even in the case of a non-sysprep OSD script, I count 13 commands after the actual image restore, before the reboot. There is no trace of these commands in your log. Your log looks as if it is ghost that rebooted the machine.


                  We haven't seen your OSD script. Can you post it?

                  1 of 1 people found this helpful
                  • 6. Re: Sysprep not applying during OSD

                    Thanks for that, i'll have a look at what the switches are doing in conjunction to the image deployment. I have attached the OSD script also.

                    • 7. Re: Sysprep not applying during OSD
                      Jared Barneck SupportEmployee

                      Did you use the correct version of Sysprep.  XP sysprep does not work on XP SP1, XP SP1 sysprep doesn't work on XP SP2, XP SP2 Sysprep doesn't work on XP

                      SP3, etc...


                      So did you sysprep with the correct version?  Sysprep will not work right if you don't sysprep with the correct version.

                      • 8. Re: Sysprep not applying during OSD

                        As you can see in the script, you have a ghost command (REMEXEC22), followed by another 18 lines before the reboot. Those 18 lines don't happen. The script never gets past the gost command line. Something is causing ghost to reboot the machine. Looking at the command line, I can't see what. There is a -rb command line switch that tells ghost to reboot, but it's not there in your script or in the log. I'm not a regular ghost user but when I look at the command line in the script, I wouldn't expect a reboot.


                        Are you absolutely sure that the log that you posted earlier, with a failed ghost command as the last tine, is what you get every time? If you are, then what you have is a ghost problem, not a sysprep problem.


                        Have you looked at the ghost session just as the machine is about the reboot? Could there be some fleeting error message from ghost?

                        • 9. Re: Sysprep not applying during OSD

                          Turns out it was the version of ghost32.exe i was using ... I upgraded it this morning and it has copied the sysprep file down correctly.


                          Thank you very much for your help Jan I really appreciate it.