1 2 3 Previous Next 34 Replies Latest reply on Aug 7, 2018 1:04 AM by Randis Go to original post
      • 30. Re: APM - viele Patch Pakete schlagen fehl
        FrankScholer Master

        Hallo zusammen,

         

        sowohl ich in meiner Testumgebung als auch ein Kunde (in der Produktion) hat auch ein ähnlich gelagertes oder sogar dasselbe Problem. Es äußert sich so, dass zunächst alle Patches sauber installiert werden (im Log Returncode jeweils 0) und die meisten natürlich einen Reboot verlangen. Die Patch Policy-Instanzen haben auch das entsprechende Reboot-Symbol.

         

        Kurz vor dem Reboot, praktisch mit dem letzten Client-Sync, gehen die Instanzen aber alle auf "Reinstall" (das "Fast Forward"-Icon) und wenn das Execution Package nach dem Neustart nochmal den Scan macht, dann auf "Not applicable or fixed externally" (weil die Patches natürlich auch wirklich sauber installiert sind und von Windows nicht mehr benötigt werden).

         

        Schließlich werden diese Patch Policy-Instanzen auch gelöscht, nämlich beim nächsten Client-Sync nach Ablauf der Zeit, wann erfolgreich deinstallierte Policy-Instanzen gelöscht werden sollen (Konfig-Tabelle Abschnitt "Automatische Datenbank-Bereinigung", Einstellung "Wartezeit bis zum Löschen deinstallierter Policy-Instanzen [min]") und man sieht überhaupt nicht mehr, dass die Patches über DSM eigentlich sauber installiert wurden...

         

        Ich habe jetzt viel rumgetestet und Logs gelesen und gestern zumindest die Ursache gefunden, wann das passiert: und zwar hatte ich bisher ein Job-Script zugewiesen, das beim Trigger "Paket-Ausführung: Erfolg" einfach ein "SendStatusUpdateToServer" macht, sodass in der DSMC immer der aktuelle Stand der Paketinstallationen zu sehen ist. Ist dieses Paket zugewiesen, tritt das Problem auf. Lösche ich die Zuweisung dieses Pakets, ist alles sauber, er installiert die Pakete, nichts geht auf "Reinstall" und nach dem Neustart sind die Policy-Instanzen compliant und die Vulnerabilities geschlossen...

         

        Offensichtlich besteht das Problem darin, dass nochmals ein Client-Sync stattfindet und dadurch der Status Reboot-Pending Status der Patch Policy-Instanzen irgendwie falsch gemeldet oder mit dem Client abgeglichen wird und die vom BLS daher auf Reinstall gesetzt werden.

         

        Ich werde mal versuchen, das mit dem Support zu klären, weil das ist m.E. eindeutig ein Bug...

         

        Grüße Frank

        2 of 2 people found this helpful
        • 32. Re: APM - viele Patch Pakete schlagen fehl
          MWiega Apprentice

          Hallo,

           

          bei uns tritt es nun scheinbar auch auf unter 2018.1 (4467).

           

          Michael

          • 33. Re: APM - viele Patch Pakete schlagen fehl
            SitzRieSe Expert

            Hi Frank,

             

            das ist genau das Problem! Kannst ja mal in deiner Umgebung testen was passiert wenn du den Scan und Install vor dem Neustart nochmal ausführst, dann gehen die Pakete nämlich auf failed! Daher mein Workaround mit dem Reboot im Execution Package, allerdings hab ich wie du beschrieben auch immer wieder Pakete die auf "Not applicable or fixed externally" gehen. Konntest du beim Support schon etwas erreichen? Wenns ne RM gibt, würde ich mich gerne ranhängen

             

            Gruß

             

            Alex

            • 34. Re: APM - viele Patch Pakete schlagen fehl
              Randis Apprentice

              Hallo Alex,

               

              die Problem Nummer ist 66285 und es liegt gerade bei der Entwicklung.

               

              Gruß

              Christian

              1 2 3 Previous Next